From c9160a88b1d4e3a03e4a9a09b5d121f8a53b3527 Mon Sep 17 00:00:00 2001
From: Florian Fainelli <florian@openwrt.org>
Date: Thu, 27 Mar 2008 15:52:29 +0000
Subject: Revert [10668] this was also accidental

SVN-Revision: 10670
---
 target/linux/atheros/image/Makefile | 34 +---------------------------------
 1 file changed, 1 insertion(+), 33 deletions(-)

(limited to 'target/linux/atheros/image/Makefile')

diff --git a/target/linux/atheros/image/Makefile b/target/linux/atheros/image/Makefile
index b8ca313e0d..d50cae5049 100644
--- a/target/linux/atheros/image/Makefile
+++ b/target/linux/atheros/image/Makefile
@@ -7,34 +7,12 @@
 include $(TOPDIR)/rules.mk
 include $(INCLUDE_DIR)/image.mk
 
-LOADADDR = 0x81000000           # RAM start + 16M
-KERNEL_ENTRY = 0x80041000
-RAMSIZE = 0x00100000            # 1MB
-IMAGE_COPY = 1
-
-LOADER_MAKEOPTS= \
-		KDIR=$(KDIR) \
-		LOADADDR=$(LOADADDR) \
-		KERNEL_ENTRY=$(KERNEL_ENTRY) \
-		RAMSIZE=$(RAMSIZE) \
-		IMAGE_COPY=$(IMAGE_COPY)
-
-define Build/Clean
-	$(MAKE) -C $(GENERIC_PLATFORM_DIR)/image/lzma-loader $(LOADER_MAKEOPTS) clean
-endef
-        
-define Image/Prepare
+define Image/BuildKernel
 	cp $(KDIR)/vmlinux.elf $(BIN_DIR)/openwrt-$(BOARD)-vmlinux.elf
 	gzip -9 -c $(KDIR)/vmlinux > $(KDIR)/vmlinux.bin.gz
 	$(STAGING_DIR_HOST)/bin/lzma e $(KDIR)/vmlinux $(KDIR)/vmlinux.bin.l7
 	dd if=$(KDIR)/vmlinux.bin.l7 of=$(BIN_DIR)/openwrt-$(BOARD)-vmlinux.lzma bs=65536 conv=sync
 	dd if=$(KDIR)/vmlinux.bin.gz of=$(BIN_DIR)/openwrt-$(BOARD)-vmlinux.gz bs=65536 conv=sync
-	cat $(KDIR)/vmlinux | $(STAGING_DIR_HOST)/bin/lzma e -si -so -eos -lc1 -lp2 -pb2 > $(KDIR)/vmlinux.lzma
-	$(MAKE) -C $(GENERIC_PLATFORM_DIR)/image/lzma-loader $(LOADER_MAKEOPTS) clean compile
-endef
-
-define Image/BuildKernel
-	$(CP) $(KDIR)/loader.bin $(BIN_DIR)/openwrt-$(BOARD)-vmlinux
 endef
 
 define Image/Build/squashfs
@@ -46,14 +24,4 @@ define Image/Build
 	dd if=$(KDIR)/root.$(1) of=$(BIN_DIR)/openwrt-$(BOARD)-root.$(1) bs=128k conv=sync
 endef
 
-ifneq ($(CONFIG_TARGET_ROOTFS_INITRAMFS),y)
-  define Image/Prepare
-	cat $(KDIR)/vmlinux | $(STAGING_DIR_HOST)/bin/lzma e -si -so -eos -lc1 -lp2 -pb2 > $(KDIR)/vmlinux.lzma
-	$(MAKE) -C $(GENERIC_PLATFORM_DIR)/image/lzma-loader $(LOADER_MAKEOPTS) clean compile
-  endef
-  define Image/BuildKernel
-	$(CP) $(KDIR)/loader.bin $(BIN_DIR)/openwrt-$(BOARD)-vmlinux
-  endef
-endif
-
 $(eval $(call BuildImage))
-- 
cgit v1.2.3