From 09a97f42d95bb97bc24328c21882eb569d7ac8df Mon Sep 17 00:00:00 2001
From: Felix Fietkau <nbd@openwrt.org>
Date: Sat, 19 Dec 2015 11:27:45 +0000
Subject: ar71xx: Image generation for PowerCloud CR3000 Cloud Router

Image generation part of support for PowerCloud CR3000.  The CR3000 is
a 802.11n 2.4 GHz wireless router with 8MB flash, 64MB RAM,
a four port fast ethernet switch, and a fast ethernet wan port which
was sold by PowerCloud Systems as hardware for the Skydog
cloud-managed router service.

Signed-off-by: Daniel Dickinson <openwrt@daniel.thecshore.com>

SVN-Revision: 47942
---
 target/linux/ar71xx/generic/profiles/pcs.mk | 18 ++++++++++++++++++
 1 file changed, 18 insertions(+)

(limited to 'target/linux/ar71xx/generic/profiles')

diff --git a/target/linux/ar71xx/generic/profiles/pcs.mk b/target/linux/ar71xx/generic/profiles/pcs.mk
index 1466e5282a..b4df1a4712 100644
--- a/target/linux/ar71xx/generic/profiles/pcs.mk
+++ b/target/linux/ar71xx/generic/profiles/pcs.mk
@@ -47,3 +47,21 @@ endef
 
 $(eval $(call Profile,CAP324))
 
+define Profile/CR3000
+	NAME:=PowerCloud CR3000 Cloud Router
+	PACKAGES:=uboot-envtools
+endef
+
+define Profile/CR3000/Description
+	Package set optimized for the PowerCloud Systems CR3000 Cloud Router
+
+	The CR3000 is a device sold by PowerCloud Systems as a hardware
+	option for their Skydog cloud-managed Wifi solution.
+
+	The CR3000 is a 2.4 GHz 802.11n wireless router with 8MB
+	flash and 64MB RAM, four-port fast ethernet switch, and fast
+	ethernet WAN port.
+endef
+
+$(eval $(call Profile,CR3000))
+
-- 
cgit v1.2.3