From 78e8360878d716c75fc98d6f93bdd61f156caa28 Mon Sep 17 00:00:00 2001
From: Adrian Schmutzler <freifunk@adrianschmutzler.de>
Date: Sat, 6 Jun 2020 23:09:59 +0200
Subject: soloscli: fix uci-defaults file

The folder for the uci-defaults file of this package is wrong, so
the file most probably has not been executed at all for several
years at least.

Fix the folder and remove the useless shebang for the file.

Signed-off-by: Adrian Schmutzler <freifunk@adrianschmutzler.de>
---
 package/network/config/soloscli/Makefile                  |  2 +-
 .../network/config/soloscli/files/etc/uci-default/solos   | 15 ---------------
 .../network/config/soloscli/files/etc/uci-defaults/solos  | 13 +++++++++++++
 3 files changed, 14 insertions(+), 16 deletions(-)
 delete mode 100644 package/network/config/soloscli/files/etc/uci-default/solos
 create mode 100644 package/network/config/soloscli/files/etc/uci-defaults/solos

(limited to 'package')

diff --git a/package/network/config/soloscli/Makefile b/package/network/config/soloscli/Makefile
index 877a0f275b..52a53dc0fa 100644
--- a/package/network/config/soloscli/Makefile
+++ b/package/network/config/soloscli/Makefile
@@ -9,7 +9,7 @@ include $(TOPDIR)/rules.mk
 
 PKG_NAME:=soloscli
 PKG_VERSION:=1.04
-PKG_RELEASE:=2
+PKG_RELEASE:=3
 
 PKG_SOURCE:=solos-pci-$(PKG_VERSION).tar.gz
 PKG_SOURCE_URL:=@SF/openadsl
diff --git a/package/network/config/soloscli/files/etc/uci-default/solos b/package/network/config/soloscli/files/etc/uci-default/solos
deleted file mode 100644
index 7f69da62c6..0000000000
--- a/package/network/config/soloscli/files/etc/uci-default/solos
+++ /dev/null
@@ -1,15 +0,0 @@
-#!/bin/sh
-
-uci batch <<__EOF__
-
-delete network.wan.solos0
-
-add_list network.wan.solos0="ActivateLine=Abort"
-add_list network.wan.solos0="Retrain=EnableAll"
-add_list network.wan.solos0="DetectNoise=Enable"
-add_list network.wan.solos0="BisMCapability=Disable"
-add_list network.wan.solos0="BisACapability=Disable"
-add_list network.wan.solos0="ActivateLine=Start"
-
-commit network
-__EOF__
diff --git a/package/network/config/soloscli/files/etc/uci-defaults/solos b/package/network/config/soloscli/files/etc/uci-defaults/solos
new file mode 100644
index 0000000000..6645fc370a
--- /dev/null
+++ b/package/network/config/soloscli/files/etc/uci-defaults/solos
@@ -0,0 +1,13 @@
+uci batch <<__EOF__
+
+delete network.wan.solos0
+
+add_list network.wan.solos0="ActivateLine=Abort"
+add_list network.wan.solos0="Retrain=EnableAll"
+add_list network.wan.solos0="DetectNoise=Enable"
+add_list network.wan.solos0="BisMCapability=Disable"
+add_list network.wan.solos0="BisACapability=Disable"
+add_list network.wan.solos0="ActivateLine=Start"
+
+commit network
+__EOF__
-- 
cgit v1.2.3