From ee65a023201a25e8a93ef172f674b50ce40e55ce Mon Sep 17 00:00:00 2001
From: Imre Kaloz <kaloz@openwrt.org>
Date: Thu, 25 Oct 2007 09:57:57 +0000
Subject: nuke util-linux in favor of util-linux-ng, build only what we need

SVN-Revision: 9444
---
 package/util-linux/Makefile | 133 --------------------------------------------
 1 file changed, 133 deletions(-)
 delete mode 100644 package/util-linux/Makefile

(limited to 'package/util-linux/Makefile')

diff --git a/package/util-linux/Makefile b/package/util-linux/Makefile
deleted file mode 100644
index 602d1d5992..0000000000
--- a/package/util-linux/Makefile
+++ /dev/null
@@ -1,133 +0,0 @@
-# 
-# Copyright (C) 2006 OpenWrt.org
-#
-# This is free software, licensed under the GNU General Public License v2.
-# See /LICENSE for more information.
-#
-# $Id$
-
-include $(TOPDIR)/rules.mk
-
-PKG_NAME:=util-linux
-PKG_VERSION:=2.12r
-PKG_RELEASE:=2
-
-PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
-PKG_SOURCE_URL:=@KERNEL/linux/utils/$(PKG_NAME)/
-PKG_MD5SUM:=c261230b27fc0fbcc287c76884caf2d3
-
-include $(INCLUDE_DIR)/package.mk
-
-define Package/util-linux/Default
-  SECTION:=utils
-  CATEGORY:=Utilities
-  DEPENDS:=@!TARGET_etrax
-  URL:=http://www.kernel.org/pub/linux/utils/util-linux/
-endef
-
-define Package/fdisk
-$(call Package/util-linux/Default)
-  TITLE:=Partition table manipulation utility
-  SUBMENU=disc
-endef
-
-define Package/fdisk/description
- This package contains a utility for managing disk partition tables.
-endef
-
-define Package/cfdisk
-$(call Package/util-linux/Default)
-  TITLE:=Partition table manipulation utility
-  DEPENDS:= +libncurses
-  SUBMENU:=disc
-endef
-
-define Package/cfdisk/description
- This package contains a utility for managing disk partition tables.
-endef
-
-define Package/losetup
-$(call Package/util-linux/Default)
-  TITLE:=Loopback devices setup and control utility
-endef
-
-define Package/losetup/description
- This package contains a utility for managing loopback devices.
-endef
-
-define Package/swap-utils
-$(call Package/util-linux/Default)
-  TITLE:=Swap space management utilities
-  SUBMENU:=disc
-endef
-
-define Package/swap-utils/description
- This package contains a collection of tools for managing swap space: 
- - mkswap
- - swapon
- - swapoff
-endef
-
-define Package/hwclock
-$(call Package/util-linux/Default)
-  TITLE:=Utilities for managing the hardware clock
-endef
-
-define Package/hwclock/description
- This package contains a utility for managing the hardware clock.
-endef
-
-define Build/Configure
-	# this is NOT GNU configure!
-	( cd $(PKG_BUILD_DIR); \
-		CC="$(TARGET_CC)" \
-		CFLAGS="$(TARGET_CPPFLAGS)" \
-		LDFLAGS="$(TARGET_LDFLAGS)" \
-		./configure \
-	);
-endef
-
-define Build/Compile
-	$(MAKE) -C $(PKG_BUILD_DIR) \
-		OPT="$(TARGET_CFLAGS)" \
-		INSTALLSUID="install -m 4755" \
-		DESTDIR="$(PKG_INSTALL_DIR)" \
-		all install
-endef
-
-define Package/Template
-	@if [ \! -f "$(PKG_INSTALL_DIR)/$(1)" ]; then \
-		rm -f $(PKG_BUILD_DIR)/.built; \
-		$(MAKE) $(PKG_BUILD_DIR)/.built; \
-	fi
-	$(INSTALL_DIR) $(2)
-	$(CP) $(PKG_INSTALL_DIR)/$(1) $(2)/
-endef
-
-define Package/fdisk/install
-	$(call Package/Template,sbin/fdisk,$(1)/usr/sbin)
-endef
-
-define Package/cfdisk/install
-	$(call Package/Template,sbin/cfdisk,$(1)/usr/sbin)
-endef
-
-define Package/losetup/install
-	$(call Package/Template,sbin/losetup,$(1)/usr/sbin)
-endef
-
-define Package/swap-utils/install
-	$(call Package/Template,sbin/mkswap,$(1)/usr/sbin)
-	$(call Package/Template,sbin/swapon,$(1)/usr/sbin)
-	$(call Package/Template,sbin/swapoff,$(1)/usr/sbin)
-endef
-
-define Package/hwclock/install
-	$(call Package/Template,sbin/hwclock,$(1)/usr/sbin)
-endef
-
-$(eval $(call BuildPackage,fdisk))
-$(eval $(call BuildPackage,cfdisk))
-$(eval $(call BuildPackage,losetup))
-$(eval $(call BuildPackage,swap-utils))
-$(eval $(call BuildPackage,hwclock))
-- 
cgit v1.2.3