From 0bc3f51aa650ec9fea995233714219d2cb63f53c Mon Sep 17 00:00:00 2001
From: Jo-Philipp Wich <jo@mein.io>
Date: Fri, 28 May 2021 15:23:14 +0200
Subject: ubox: fix init script validation of log_ip option

The underlying logread process uses usock() to handle remote connections
which is able to handle both hostnames and IP addresses.

Ref: https://github.com/openwrt/luci/issues/5077
Signed-off-by: Jo-Philipp Wich <jo@mein.io>
(cherry picked from commit ec83fb9ced138b7945135adffb9ff0ba63b695ec)
---
 package/system/ubox/Makefile       | 2 +-
 package/system/ubox/files/log.init | 2 +-
 2 files changed, 2 insertions(+), 2 deletions(-)

(limited to 'package/system/ubox')

diff --git a/package/system/ubox/Makefile b/package/system/ubox/Makefile
index f32e93ca80..9ba4abdd58 100644
--- a/package/system/ubox/Makefile
+++ b/package/system/ubox/Makefile
@@ -1,7 +1,7 @@
 include $(TOPDIR)/rules.mk
 
 PKG_NAME:=ubox
-PKG_RELEASE:=1
+PKG_RELEASE:=2
 
 PKG_SOURCE_PROTO:=git
 PKG_SOURCE_URL=$(PROJECT_GIT)/project/ubox.git
diff --git a/package/system/ubox/files/log.init b/package/system/ubox/files/log.init
index 250f805b44..c4802d4199 100644
--- a/package/system/ubox/files/log.init
+++ b/package/system/ubox/files/log.init
@@ -15,7 +15,7 @@ validate_log_section()
 		'log_file:string' \
 		'log_size:uinteger' \
 		'log_hostname:string' \
-		'log_ip:ipaddr' \
+		'log_ip:host' \
 		'log_remote:bool:1' \
 		'log_port:port:514' \
 		'log_proto:or("tcp", "udp"):udp' \
-- 
cgit v1.2.3