From 648bc811f0ae9af96609c1cc6df616a37dad7dbb Mon Sep 17 00:00:00 2001
From: Felix Fietkau <nbd@openwrt.org>
Date: Wed, 14 Aug 2013 13:02:33 +0000
Subject: openssl: to disable mips16, use the new PKG_USE_MIPS16 flag instead
 of messing with cflags directly

Signed-off-by: Felix Fietkau <nbd@openwrt.org>

SVN-Revision: 37771
---
 package/libs/openssl/Makefile | 3 ++-
 1 file changed, 2 insertions(+), 1 deletion(-)

(limited to 'package/libs')

diff --git a/package/libs/openssl/Makefile b/package/libs/openssl/Makefile
index 8b0f5243bb..8f4f93d852 100644
--- a/package/libs/openssl/Makefile
+++ b/package/libs/openssl/Makefile
@@ -10,6 +10,7 @@ include $(TOPDIR)/rules.mk
 PKG_NAME:=openssl
 PKG_VERSION:=1.0.1e
 PKG_RELEASE:=2
+PKG_USE_MIPS16:=0
 
 PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
 PKG_SOURCE_URL:=http://www.openssl.org/source/ \
@@ -120,7 +121,7 @@ define Build/Configure
 	)
 endef
 
-TARGET_CFLAGS := $(filter-out -mips16 -minterlink-mips16,$(TARGET_CFLAGS)) $(FPIC)
+TARGET_CFLAGS += $(FPIC)
 
 define Build/Compile
 	# XXX: OpenSSL "make depend" will look for installed headers before its own,
-- 
cgit v1.2.3