From 89124c8a0ab1baeb926108bb8dd503c24a25b75d Mon Sep 17 00:00:00 2001
From: Nicolas Thill <nico@openwrt.org>
Date: Wed, 20 Aug 2008 22:00:41 +0000
Subject: move more extra packages from ./trunk to ./packages

SVN-Revision: 12359
---
 package/keynote/Makefile | 55 ------------------------------------------------
 1 file changed, 55 deletions(-)
 delete mode 100644 package/keynote/Makefile

(limited to 'package/keynote/Makefile')

diff --git a/package/keynote/Makefile b/package/keynote/Makefile
deleted file mode 100644
index 5b27257b4a..0000000000
--- a/package/keynote/Makefile
+++ /dev/null
@@ -1,55 +0,0 @@
-# 
-# Copyright (C) 2006 OpenWrt.org
-#
-# This is free software, licensed under the GNU General Public License v2.
-# See /LICENSE for more information.
-#
-# $Id$
-
-include $(TOPDIR)/rules.mk
-
-PKG_NAME:=keynote
-PKG_VERSION:=2.3
-PKG_RELEASE:=2
-
-PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.bz2
-PKG_SOURCE_URL:=http://downloads.openwrt.org/sources/
-PKG_MD5SUM:=b569066ac2ba1356c2112b118a7d74d0
-
-include $(INCLUDE_DIR)/package.mk
-
-define Package/keynote
-  SECTION:=net
-  CATEGORY:=Network
-  DEPENDS:=@LINUX_2_6 +libopenssl
-  TITLE:=Simple and flexible trust-management system
-  URL:=http://www1.cs.columbia.edu/~angelos/keynote.html
-endef
-
-define Package/keynote/description
- KeyNote is a simple and flexible trust-management system designed to work 
- well for a variety of large- and small- scale Internet-based applications.
- It provides a single, unified language for both local policies and 
- credentials.
-endef
-
-CONFIGURE_ARGS += \
-	--enable-static \
-	--enable-shared
-
-MAKE_FLAGS += \
-	CFLAGS="$(TARGET_CFLAGS)"
-
-define Build/InstallDev
-	mkdir -p $(1)/usr/include/keynote
-	$(CP) $(PKG_BUILD_DIR)/{assertion,header,keynote,signature}.h $(1)/usr/include/keynote/
-	mkdir -p $(1)/usr/lib
-	$(CP) $(PKG_BUILD_DIR)/libkeynote.a $(1)/usr/lib/
-endef
-
-define Package/keynote/install
-	$(INSTALL_DIR) $(1)/usr/sbin
-	$(INSTALL_BIN) $(PKG_BUILD_DIR)/keynote $(1)/usr/sbin/
-endef
-
-$(eval $(call BuildPackage,keynote))
-- 
cgit v1.2.3