From 15ea1a6d66c3395a2c87fa9ff4bdea59ac5c2a6d Mon Sep 17 00:00:00 2001
From: Luka Perkov <luka@openwrt.org>
Date: Thu, 12 Sep 2013 23:38:54 +0000
Subject: kernel: gsc depends on kmod-i2c-core

Signed-off-by: Luka Perkov <luka@openwrt.org>

SVN-Revision: 37960
---
 package/kernel/linux/modules/hwmon.mk | 6 +++---
 1 file changed, 3 insertions(+), 3 deletions(-)

(limited to 'package/kernel')

diff --git a/package/kernel/linux/modules/hwmon.mk b/package/kernel/linux/modules/hwmon.mk
index b1f4744330..54e9b180b3 100644
--- a/package/kernel/linux/modules/hwmon.mk
+++ b/package/kernel/linux/modules/hwmon.mk
@@ -211,7 +211,7 @@ define KernelPackage/hwmon-w83627hf
   KCONFIG:=CONFIG_SENSORS_W83627HF
   FILES:=$(LINUX_DIR)/drivers/hwmon/w83627hf.ko
   AUTOLOAD:=$(call AutoLoad,50,w83627hf)
-$(call AddDepends/hwmon,@TARGET_rdc||TARGET_x86 +kmod-hwmon-vid)
+  $(call AddDepends/hwmon,@TARGET_rdc||TARGET_x86 +kmod-hwmon-vid)
 endef
 
 define KernelPacakge/hwmon-w83627hf/description
@@ -225,8 +225,8 @@ define KernelPackage/hwmon-gsc
   TITLE:=Gateworks GSC monitoring support
   KCONFIG:=CONFIG_SENSORS_GSC
   FILES:=$(LINUX_DIR)/drivers/hwmon/gsc.ko
-  AUTOLOAD:=$(call AutoLoad,50,gsc)
-$(call AddDepends/hwmon)
+  AUTOLOAD:=$(call AutoLoad,60,gsc)
+  $(call AddDepends/hwmon,+kmod-i2c-core)
 endef
 
 define KernelPacakge/hwmon-gsc/description
-- 
cgit v1.2.3