From 0aa351196ae3c5262b38a61dab6d1672b4070a2f Mon Sep 17 00:00:00 2001
From: Nicolas Thill <nico@openwrt.org>
Date: Fri, 26 Jun 2015 00:43:03 +0000
Subject: mac80211: fix build on UML

A duplicate include guard prevents inclusion of barrier.h in UML build and this prevents mac80211 from building.

This patch re-enables mac80211 hwsim and renames the include guard.

See https://lists.openwrt.org/pipermail/openwrt-devel/2015-June/033614.html for details.

Signed-off-by: Martin Tippmann <martin.tippmann@gmail.com>
Signed-off-by: Nicolas Thill <nico@openwrt.org>

SVN-Revision: 46133
---
 package/kernel/mac80211/Makefile                        |  2 +-
 package/kernel/mac80211/patches/010-fix-uml-build.patch | 15 +++++++++++++++
 2 files changed, 16 insertions(+), 1 deletion(-)
 create mode 100644 package/kernel/mac80211/patches/010-fix-uml-build.patch

(limited to 'package/kernel/mac80211')

diff --git a/package/kernel/mac80211/Makefile b/package/kernel/mac80211/Makefile
index 344fbd80c5..be26348a13 100644
--- a/package/kernel/mac80211/Makefile
+++ b/package/kernel/mac80211/Makefile
@@ -60,7 +60,7 @@ define KernelPackage/mac80211/Default
   SUBMENU:=$(WMENU)
   URL:=https://wireless.wiki.kernel.org/
   MAINTAINER:=Felix Fietkau <nbd@openwrt.org>
-  DEPENDS:=@!TARGET_uml @!LINUX_4_1
+  DEPENDS:=@!LINUX_4_1
 endef
 
 define KernelPackage/cfg80211
diff --git a/package/kernel/mac80211/patches/010-fix-uml-build.patch b/package/kernel/mac80211/patches/010-fix-uml-build.patch
new file mode 100644
index 0000000000..0d53e0811e
--- /dev/null
+++ b/package/kernel/mac80211/patches/010-fix-uml-build.patch
@@ -0,0 +1,15 @@
+--- a/backport-include/asm/barrier.h
++++ b/backport-include/asm/barrier.h
+@@ -1,9 +1,9 @@
+-#ifndef __BACKPORT_ASM_GENERIC_BARRIER_H
+-#define __BACKPORT_ASM_GENERIC_BARRIER_H
++#ifndef __BACKPORT_ASM_BARRIER_H
++#define __BACKPORT_ASM_BARRIER_H
+ #include_next <asm/barrier.h>
+ 
+ #ifndef dma_rmb
+ #define dma_rmb()	rmb()
+ #endif
+ 
+-#endif /* __BACKPORT_ASM_GENERIC_BARRIER_H */
++#endif /* __BACKPORT_ASM_BARRIER_H */
-- 
cgit v1.2.3