From 84bd74057f0d2543ddbc7de2351b0a310df329c6 Mon Sep 17 00:00:00 2001
From: Felix Fietkau <nbd@nbd.name>
Date: Sun, 25 Dec 2016 16:40:05 +0100
Subject: build: use mkhash to replace various quirky md5sum/openssl calls

Signed-off-by: Felix Fietkau <nbd@nbd.name>
---
 package/kernel/linux/Makefile | 2 +-
 1 file changed, 1 insertion(+), 1 deletion(-)

(limited to 'package/kernel/linux')

diff --git a/package/kernel/linux/Makefile b/package/kernel/linux/Makefile
index 7f38f3e6e2..c2d10ec188 100644
--- a/package/kernel/linux/Makefile
+++ b/package/kernel/linux/Makefile
@@ -24,7 +24,7 @@ export SHELL:=/bin/sh
 include $(INCLUDE_DIR)/package.mk
 
 ifeq ($(DUMP),)
-  STAMP_BUILT:=$(STAMP_BUILT)_$(firstword $(shell $(SCRIPT_DIR)/kconfig.pl $(LINUX_DIR)/.config | md5sum))
+  STAMP_BUILT:=$(STAMP_BUILT)_$(shell $(SCRIPT_DIR)/kconfig.pl $(LINUX_DIR)/.config | mkhash md5)
   -include $(LINUX_DIR)/.config
 endif
 
-- 
cgit v1.2.3