From 0a864f20fb7fae4e3393ef1683d8ab646d2be2f4 Mon Sep 17 00:00:00 2001
From: Hauke Mehrtens <hauke@hauke-m.de>
Date: Sun, 9 Aug 2020 14:42:14 +0200
Subject: bintuils: Pack libctf-nobfd.so in addition

readelf is linked against this library on MIPS64BE
This fixes a build problem on MIPS64BE.

In addition also explicitly activate it in the configure command.

Fixes: 60f595daab45 ("binutils: update to version 2.34")
Signed-off-by: Hauke Mehrtens <hauke@hauke-m.de>
---
 package/devel/binutils/Makefile | 5 +++--
 1 file changed, 3 insertions(+), 2 deletions(-)

(limited to 'package/devel/binutils/Makefile')

diff --git a/package/devel/binutils/Makefile b/package/devel/binutils/Makefile
index 6ad326efa0..9f7a0724f4 100644
--- a/package/devel/binutils/Makefile
+++ b/package/devel/binutils/Makefile
@@ -84,7 +84,8 @@ CONFIGURE_ARGS += \
 	--target=$(REAL_GNU_TARGET_NAME) \
 	--enable-shared \
 	--enable-install-libiberty \
-	--enable-install-libbfd
+	--enable-install-libbfd \
+	--enable-install-libctf
 
 define Build/Install
 	$(call Build/Install/Default)
@@ -106,7 +107,7 @@ endef
 
 define Package/libctf/install
 	$(INSTALL_DIR) $(1)/usr/lib
-	$(CP) $(PKG_INSTALL_DIR)/usr/lib/libctf.so* $(1)/usr/lib/
+	$(CP) $(PKG_INSTALL_DIR)/usr/lib/libctf*.so* $(1)/usr/lib/
 endef
 
 define Package/libopcodes/install
-- 
cgit v1.2.3