From fd79eb4e7c04b03d0301120c04311e54995e8d24 Mon Sep 17 00:00:00 2001
From: John Crispin <john@openwrt.org>
Date: Thu, 25 Apr 2013 19:03:09 +0000
Subject: ramips: add profile for Dlink DIR-615 H1

Hello,
this adds the profile for Dlink DIR-615 H1 without the usb default packages
since this router does not have a usb port and while all the needed definitions
for building are already in target/linux/ramips/image/Makefile this also allows
users to select the exact target in RT305x based boards menuconfig for this router
and compile its firmware.

Signed-off-by: Daniel Petre <dani@ip6.ro>
Patchwork: http://patchwork.openwrt.org/patch/3529/
Acked-by: John Crispin <blogic@openwrt.org>

SVN-Revision: 36437
---
 linux/ramips/rt305x/profiles/dlink.mk | 20 ++++++++++++++++++++
 1 file changed, 20 insertions(+)
 create mode 100644 linux/ramips/rt305x/profiles/dlink.mk

(limited to 'linux/ramips')

diff --git a/linux/ramips/rt305x/profiles/dlink.mk b/linux/ramips/rt305x/profiles/dlink.mk
new file mode 100644
index 0000000000..29d8b7c38a
--- /dev/null
+++ b/linux/ramips/rt305x/profiles/dlink.mk
@@ -0,0 +1,20 @@
+#
+# Copyright (C) 2013 OpenWrt.org
+#
+# This is free software, licensed under the GNU General Public License v2.
+# See /LICENSE for more information.
+#
+
+define Profile/DIR615H1
+	NAME:=Dlink DIR-615 H1
+        PACKAGES:=\
+                -kmod-usb-core -kmod-usb-rt305x-dwc_otg \
+                -kmod-ledtrig-usbdev
+endef
+
+define Profile/DIR615H1/Description
+	Package set for Dlink DIR-615 H1 board
+endef
+
+$(eval $(call Profile,DIR615H1))
+
-- 
cgit v1.2.3