From e09067b221cbea860a7d830dc84a259810f1501d Mon Sep 17 00:00:00 2001
From: Travis Kemen <thepeople@openwrt.org>
Date: Fri, 5 Mar 2010 20:19:48 +0000
Subject: The attached patch replaces $(1) install by $(if $(1), $(1), install)
 in the definition, in order to be able to specify an install rule, which is
 not always called install (example: trunk/package/ncurses/Makefile has rules
 called install.libs and install.data).

Then its possible to do this in ncurses Makefile:

define Build/Install
       $(call Build/Install/Default, install.libs install.data)
endef

This patch does not affect anything else, as if no parameter is given,
it will use install as before.

-Raphael

SVN-Revision: 19996
---
 include/package-defaults.mk | 2 +-
 1 file changed, 1 insertion(+), 1 deletion(-)

(limited to 'include')

diff --git a/include/package-defaults.mk b/include/package-defaults.mk
index 017a86d1e8..ecc3af499f 100644
--- a/include/package-defaults.mk
+++ b/include/package-defaults.mk
@@ -122,7 +122,7 @@ define Build/Install/Default
 	$(MAKE_VARS) \
 	$(MAKE) -C $(PKG_BUILD_DIR)/$(MAKE_PATH) \
 		$(MAKE_INSTALL_FLAGS) \
-		$(1) install;
+		$(if $(1), $(1), install);
 endef
 
 define Build/Dist/Default
-- 
cgit v1.2.3