From f08a10f2b98535c256cc4066c6c90b746890b820 Mon Sep 17 00:00:00 2001
From: =?UTF-8?q?Rafa=C5=82=20Mi=C5=82ecki?= <zajec5@gmail.com>
Date: Wed, 27 May 2015 13:54:19 +0000
Subject: brcm47xx: build image for Asus RT-N66U
MIME-Version: 1.0
Content-Type: text/plain; charset=UTF-8
Content-Transfer-Encoding: 8bit

Signed-off-by: Rafał Miłecki <zajec5@gmail.com>

SVN-Revision: 45774
---
 target/linux/brcm47xx/image/Makefile | 20 ++++++++++++++++++++
 1 file changed, 20 insertions(+)

diff --git a/target/linux/brcm47xx/image/Makefile b/target/linux/brcm47xx/image/Makefile
index a3c8489f19..c6ec0fe90c 100644
--- a/target/linux/brcm47xx/image/Makefile
+++ b/target/linux/brcm47xx/image/Makefile
@@ -116,6 +116,11 @@ define Build/trx-with-loader
 		$(call trxalign/$(FILESYSTEM),$(FILESYSTEM))
 endef
 
+define Build/asus-trx
+	$(STAGING_DIR_HOST)/bin/asustrx -p $(PRODUCTID) -i $@ -o $@.new
+	mv $@.new $@
+endef
+
 define Build/linksys-bin
 	$(STAGING_DIR_HOST)/bin/addpattern -4 -p $(DEVICE_ID) -v v$(VERSION) -i $@ -o $@.new
 	mv $@.new $@
@@ -134,6 +139,7 @@ endef
 # Devices
 #################################################
 
+DEVICE_VARS += PRODUCTID
 DEVICE_VARS += DEVICE_ID VERSION
 DEVICE_VARS += BOARD_ID REGION
 
@@ -146,6 +152,19 @@ define Device/Default
 	IMAGE/trx := trx-with-loader
 endef
 
+define Device/asus
+	IMAGES := trx
+	IMAGE/trx := trx-with-loader | asus-trx
+endef
+
+define AsusDevice
+  define Device/asus-$(1)
+	$$(Device/asus)
+	PRODUCTID := $(2)
+  endef
+  TARGET_DEVICES += asus-$(1)
+endef
+
 define Device/linksys
 	IMAGES := bin
 	IMAGE/bin := trx-with-loader | linksys-bin
@@ -263,6 +282,7 @@ endif
 #################################################
 
 ifeq ($(SUBTARGET),mips74k)
+  $(eval $(call AsusDevice,rt-n66u,RT-N66U))
   $(eval $(call LinksysDevice,wrt160n-v3,N150,3.0.3))
   $(eval $(call LinksysDevice,wrt310n-v2,310N,2.0.1))
   $(eval $(call LinksysDevice,wrt320n-v1,320N,1.0.5))
-- 
cgit v1.2.3