From edbb32897ac070c3a9462e1fd9fa21d135d642b9 Mon Sep 17 00:00:00 2001
From: Jo-Philipp Wich <jow@openwrt.org>
Date: Tue, 26 May 2015 11:37:05 +0000
Subject: build: trigger pacakge index creation for all feeds if required

When CONFIG_PER_FEED_REPO_ADD_DISABLED is set, trigger index creation for
any available feed, regardless of whether there where binaries built or not.

Signed-off-by: Jo-Philipp Wich <jow@openwrt.org>

SVN-Revision: 45765
---
 package/Makefile | 6 +++++-
 1 file changed, 5 insertions(+), 1 deletion(-)

diff --git a/package/Makefile b/package/Makefile
index 94b807f5d5..a601dcbb31 100644
--- a/package/Makefile
+++ b/package/Makefile
@@ -132,7 +132,11 @@ endif
 
 PACKAGE_SUBDIRS=.
 ifneq ($(CONFIG_PER_FEED_REPO),)
-  PACKAGE_SUBDIRS=base $(FEEDS_ENABLED)
+  ifneq ($(CONFIG_PER_FEED_REPO_ADD_DISABLED),)
+    PACKAGE_SUBDIRS=base $(FEEDS_AVAILABLE)
+  else
+    PACKAGE_SUBDIRS=base $(FEEDS_ENABLED)
+  endif
 endif
 
 $(curdir)/index: FORCE
-- 
cgit v1.2.3