From ead555a94ac5363cc751353d12ff7482854d4c06 Mon Sep 17 00:00:00 2001
From: Jonas Gorski <jogo@openwrt.org>
Date: Tue, 3 Mar 2015 14:39:49 +0000
Subject: generic: upgrade to 3.18.8

Fixes several issues in the network stack.

Full changelog:
* https://www.kernel.org/pub/linux/kernel/v3.x/ChangeLog-3.18.8

Signed-off-by: Jonas Gorski <jogo@openwrt.org>

SVN-Revision: 44593
---
 include/kernel-version.mk                              |  4 ++--
 .../patches-3.18/662-use_fq_codel_by_default.patch     |  2 +-
 ...w-rejecting-with-source-address-failed-policy.patch | 18 +++++++++---------
 3 files changed, 12 insertions(+), 12 deletions(-)

diff --git a/include/kernel-version.mk b/include/kernel-version.mk
index 01b90c23dd..da88a5f807 100644
--- a/include/kernel-version.mk
+++ b/include/kernel-version.mk
@@ -6,7 +6,7 @@ LINUX_VERSION-3.8  = .13
 LINUX_VERSION-3.10 = .58
 LINUX_VERSION-3.13 = .7
 LINUX_VERSION-3.14 = .32
-LINUX_VERSION-3.18 = .7
+LINUX_VERSION-3.18 = .8
 LINUX_VERSION-3.19 = 
 LINUX_VERSION-4.0 = -rc1
 
@@ -14,7 +14,7 @@ LINUX_KERNEL_MD5SUM-3.8.13  = 2af19d06cd47ec459519159cdd10542d
 LINUX_KERNEL_MD5SUM-3.10.58 = 3ff3478b6351143cef22d4b81cf48b01
 LINUX_KERNEL_MD5SUM-3.13.7  = 370adced5e5c1cb1d0d621c2dae2723f
 LINUX_KERNEL_MD5SUM-3.14.32 = 3178fb8f6f1eafcffdd730fec68754f8
-LINUX_KERNEL_MD5SUM-3.18.7  = b4ff3e1d591f7464e678c43d421c85fc
+LINUX_KERNEL_MD5SUM-3.18.8  = 94673d5f4521a6077eb6fe0ab2633b35
 LINUX_KERNEL_MD5SUM-3.19    = d3fc8316d4d4d04b65cbc2d70799e763
 LINUX_KERNEL_MD5SUM-4.0-rc1 = 547b340dca94d358b68d2658822080fa
 
diff --git a/target/linux/generic/patches-3.18/662-use_fq_codel_by_default.patch b/target/linux/generic/patches-3.18/662-use_fq_codel_by_default.patch
index 6a67a894a9..9af740daf3 100644
--- a/target/linux/generic/patches-3.18/662-use_fq_codel_by_default.patch
+++ b/target/linux/generic/patches-3.18/662-use_fq_codel_by_default.patch
@@ -32,7 +32,7 @@
  {
 --- a/include/net/sch_generic.h
 +++ b/include/net/sch_generic.h
-@@ -344,6 +344,7 @@ extern struct Qdisc noop_qdisc;
+@@ -341,6 +341,7 @@ extern struct Qdisc noop_qdisc;
  extern struct Qdisc_ops noop_qdisc_ops;
  extern struct Qdisc_ops pfifo_fast_ops;
  extern struct Qdisc_ops mq_qdisc_ops;
diff --git a/target/linux/generic/patches-3.18/670-ipv6-allow-rejecting-with-source-address-failed-policy.patch b/target/linux/generic/patches-3.18/670-ipv6-allow-rejecting-with-source-address-failed-policy.patch
index d76375efa6..80926deb43 100644
--- a/target/linux/generic/patches-3.18/670-ipv6-allow-rejecting-with-source-address-failed-policy.patch
+++ b/target/linux/generic/patches-3.18/670-ipv6-allow-rejecting-with-source-address-failed-policy.patch
@@ -143,7 +143,7 @@ Signed-off-by: Jonas Gorski <jogo@openwrt.org>
  static const struct rt6_info ip6_blk_hole_entry_template = {
  	.dst = {
  		.__refcnt	= ATOMIC_INIT(1),
-@@ -1581,6 +1598,11 @@ int ip6_route_add(struct fib6_config *cf
+@@ -1578,6 +1595,11 @@ int ip6_route_add(struct fib6_config *cf
  			rt->dst.output = ip6_pkt_prohibit_out;
  			rt->dst.input = ip6_pkt_prohibit;
  			break;
@@ -155,7 +155,7 @@ Signed-off-by: Jonas Gorski <jogo@openwrt.org>
  		case RTN_THROW:
  		default:
  			rt->dst.error = (cfg->fc_type == RTN_THROW) ? -EAGAIN
-@@ -2142,6 +2164,17 @@ static int ip6_pkt_prohibit_out(struct s
+@@ -2139,6 +2161,17 @@ static int ip6_pkt_prohibit_out(struct s
  	return ip6_pkt_drop(skb, ICMPV6_ADM_PROHIBITED, IPSTATS_MIB_OUTNOROUTES);
  }
  
@@ -173,7 +173,7 @@ Signed-off-by: Jonas Gorski <jogo@openwrt.org>
  /*
   *	Allocate a dst for local (unicast / anycast) address.
   */
-@@ -2365,7 +2398,8 @@ static int rtm_to_fib6_config(struct sk_
+@@ -2362,7 +2395,8 @@ static int rtm_to_fib6_config(struct sk_
  	if (rtm->rtm_type == RTN_UNREACHABLE ||
  	    rtm->rtm_type == RTN_BLACKHOLE ||
  	    rtm->rtm_type == RTN_PROHIBIT ||
@@ -183,7 +183,7 @@ Signed-off-by: Jonas Gorski <jogo@openwrt.org>
  		cfg->fc_flags |= RTF_REJECT;
  
  	if (rtm->rtm_type == RTN_LOCAL)
-@@ -2567,6 +2601,9 @@ static int rt6_fill_node(struct net *net
+@@ -2564,6 +2598,9 @@ static int rt6_fill_node(struct net *net
  		case -EACCES:
  			rtm->rtm_type = RTN_PROHIBIT;
  			break;
@@ -193,7 +193,7 @@ Signed-off-by: Jonas Gorski <jogo@openwrt.org>
  		case -EAGAIN:
  			rtm->rtm_type = RTN_THROW;
  			break;
-@@ -2820,6 +2857,8 @@ static int ip6_route_dev_notify(struct n
+@@ -2817,6 +2854,8 @@ static int ip6_route_dev_notify(struct n
  #ifdef CONFIG_IPV6_MULTIPLE_TABLES
  		net->ipv6.ip6_prohibit_entry->dst.dev = dev;
  		net->ipv6.ip6_prohibit_entry->rt6i_idev = in6_dev_get(dev);
@@ -202,7 +202,7 @@ Signed-off-by: Jonas Gorski <jogo@openwrt.org>
  		net->ipv6.ip6_blk_hole_entry->dst.dev = dev;
  		net->ipv6.ip6_blk_hole_entry->rt6i_idev = in6_dev_get(dev);
  #endif
-@@ -3036,6 +3075,17 @@ static int __net_init ip6_route_net_init
+@@ -3033,6 +3072,17 @@ static int __net_init ip6_route_net_init
  	net->ipv6.ip6_blk_hole_entry->dst.ops = &net->ipv6.ip6_dst_ops;
  	dst_init_metrics(&net->ipv6.ip6_blk_hole_entry->dst,
  			 ip6_template_metrics, true);
@@ -220,7 +220,7 @@ Signed-off-by: Jonas Gorski <jogo@openwrt.org>
  #endif
  
  	net->ipv6.sysctl.flush_delay = 0;
-@@ -3054,6 +3104,8 @@ out:
+@@ -3051,6 +3101,8 @@ out:
  	return ret;
  
  #ifdef CONFIG_IPV6_MULTIPLE_TABLES
@@ -229,7 +229,7 @@ Signed-off-by: Jonas Gorski <jogo@openwrt.org>
  out_ip6_prohibit_entry:
  	kfree(net->ipv6.ip6_prohibit_entry);
  out_ip6_null_entry:
-@@ -3071,6 +3123,7 @@ static void __net_exit ip6_route_net_exi
+@@ -3068,6 +3120,7 @@ static void __net_exit ip6_route_net_exi
  #ifdef CONFIG_IPV6_MULTIPLE_TABLES
  	kfree(net->ipv6.ip6_prohibit_entry);
  	kfree(net->ipv6.ip6_blk_hole_entry);
@@ -237,7 +237,7 @@ Signed-off-by: Jonas Gorski <jogo@openwrt.org>
  #endif
  	dst_entries_destroy(&net->ipv6.ip6_dst_ops);
  }
-@@ -3167,6 +3220,9 @@ int __init ip6_route_init(void)
+@@ -3164,6 +3217,9 @@ int __init ip6_route_init(void)
  	init_net.ipv6.ip6_prohibit_entry->rt6i_idev = in6_dev_get(init_net.loopback_dev);
  	init_net.ipv6.ip6_blk_hole_entry->dst.dev = init_net.loopback_dev;
  	init_net.ipv6.ip6_blk_hole_entry->rt6i_idev = in6_dev_get(init_net.loopback_dev);
-- 
cgit v1.2.3