From dc0a4f8ff86a949e255029ee50ef55b4d6e63259 Mon Sep 17 00:00:00 2001
From: John Crispin <john@openwrt.org>
Date: Tue, 16 Oct 2007 21:02:36 +0000
Subject: added rtl8169, from #2554

SVN-Revision: 9339
---
 package/kernel/modules/network.mk | 16 ++++++++++++++++
 target/linux/x86/config-2.6.23    |  3 +++
 2 files changed, 19 insertions(+)

diff --git a/package/kernel/modules/network.mk b/package/kernel/modules/network.mk
index 715051379f..4794941ef5 100644
--- a/package/kernel/modules/network.mk
+++ b/package/kernel/modules/network.mk
@@ -681,6 +681,22 @@ endef
 $(eval $(call KernelPackage,e1000))
 
 
+define KernelPackage/r8169
+  SUBMENU:=$(NETWORK_DEVICES_MENU)
+  TITLE:=Realtek 8169 gigabit ethernet support
+  DEPENDS:=@TARGET_x86
+  KCONFIG:=CONFIG_R8169
+  FILES:=$(LINUX_DIR)/drivers/net/r8169.$(LINUX_KMOD_SUFFIX)
+  AUTOLOAD:=$(call AutoLoad,50,r8169)
+endef
+
+define KernelPackage/r8169/description
+ Kernel modules for Realtek 8169 gigabit ethernet support.
+endef
+
+$(eval $(call KernelPackage,r8169))
+
+
 define KernelPackage/3c59x
   SUBMENU:=$(NETWORK_DEVICES_MENU)
   TITLE:=3Com 3c590/3c900 series (592/595/597) Vortex/Boomerang
diff --git a/target/linux/x86/config-2.6.23 b/target/linux/x86/config-2.6.23
index 963069675c..3be125911a 100644
--- a/target/linux/x86/config-2.6.23
+++ b/target/linux/x86/config-2.6.23
@@ -288,6 +288,9 @@ CONFIG_PNP=y
 # CONFIG_PNP_DEBUG is not set
 CONFIG_PREEMPT_BKL=y
 CONFIG_QUICKLIST=y
+CONFIG_R8169=m
+CONFIG_R8169_NAPI=y
+# CONFIG_R8169_VLAN is not set
 # CONFIG_RELOCATABLE is not set
 CONFIG_RTC=y
 CONFIG_RWSEM_GENERIC_SPINLOCK=y
-- 
cgit v1.2.3