From ccbc63577061c015dee6019d134d0ab990eb5cdd Mon Sep 17 00:00:00 2001
From: Florian Fainelli <florian@openwrt.org>
Date: Sun, 14 Oct 2007 18:39:20 +0000
Subject: Allow kexec to directly use the kernel exposed in a mtd partition and
 reboot using the right command line

SVN-Revision: 9322
---
 package/kexec-tools/Makefile       | 1 +
 package/kexec-tools/files/kexec.sh | 5 +++++
 2 files changed, 6 insertions(+)
 create mode 100644 package/kexec-tools/files/kexec.sh

diff --git a/package/kexec-tools/Makefile b/package/kexec-tools/Makefile
index d31aeaa856..6274cb81c3 100644
--- a/package/kexec-tools/Makefile
+++ b/package/kexec-tools/Makefile
@@ -48,6 +48,7 @@ define Package/kexec-tools/install
 	$(INSTALL_DIR) $(1)/usr/bin
 	$(INSTALL_BIN) $(PKG_INSTALL_DIR)/usr/sbin/kexec $(1)/usr/bin/
 	$(INSTALL_BIN) $(PKG_INSTALL_DIR)/usr/sbin/kdump $(1)/usr/bin/
+	$(INSTALL_BIN) ./files/kexec.sh $(1)/usr/bin/kexec.mtd
 endef
 
 $(eval $(call BuildPackage,kexec-tools))
diff --git a/package/kexec-tools/files/kexec.sh b/package/kexec-tools/files/kexec.sh
new file mode 100644
index 0000000000..8871d8aeb9
--- /dev/null
+++ b/package/kexec-tools/files/kexec.sh
@@ -0,0 +1,5 @@
+#!/bin/sh
+. /etc/functions.sh
+cmdline="$(cat /proc/cmdline)"
+kernel="$(find_mtd_part kernel)"
+kexec -l $kernel --command-line=$cmdline
-- 
cgit v1.2.3