From b99dfc713360fe497da88fa1ee12b539d4d68859 Mon Sep 17 00:00:00 2001
From: Florian Fainelli <florian@openwrt.org>
Date: Sun, 1 Apr 2007 11:06:32 +0000
Subject: Restore image creation for rdc boards

SVN-Revision: 6780
---
 target/linux/rdc-2.6/image/Makefile | 12 +++++++++---
 1 file changed, 9 insertions(+), 3 deletions(-)

diff --git a/target/linux/rdc-2.6/image/Makefile b/target/linux/rdc-2.6/image/Makefile
index dc54bc5b6b..6c733087c2 100644
--- a/target/linux/rdc-2.6/image/Makefile
+++ b/target/linux/rdc-2.6/image/Makefile
@@ -11,10 +11,16 @@ define Image/Prepare
 	$(CP) $(LINUX_DIR)/arch/i386/boot/bzImage $(KDIR)/bzImage
 endef
 
+define Image/Build/Airlink
+	touch $(BIN_DIR)/openwrt-$(BOARD)-$(KERNEL)-$(3)-$(2).img
+	$(STAGING_DIR)/bin/airlink -b 1 -j 64 $(KDIR)/bzImage $(KDIR)/root.$(1) $(BIN_DIR)/openwrt-$(BOARD)-$(KERNEL)-$(3)-$(2).img
+endef
+
 define Image/Build
-	# FIXME
-	#touch $(BIN_DIR)/openwrt-$(BOARD)-$(KERNEL)-$(1).img
-	#$(STAGING_DIR)/bin/airlink -b 0 -j $(KDIR)/bzImage $(KDIR)/root.$(1) $(BIN_DIR)/openwrt-$(BOARD)-$(KERNEL)-$(1).img
+	$(CP) $(KDIR)/bzImage $(BIN_DIR)/openwrt-$(BOARD)-$(KERNEL).bzImage
+ifneq ($(1),jffs2-128K)
+	$(call Image/Build/Airlink,$(1),ar525w,$(patsubst jffs2-%,jffs2,$(1)))
+endif
 endef
 
 $(eval $(call BuildImage))
-- 
cgit v1.2.3