From 9c14920205732d65aeda38e93fb44138ce6a55ce Mon Sep 17 00:00:00 2001
From: Jo-Philipp Wich <jow@openwrt.org>
Date: Thu, 7 May 2009 13:18:44 +0000
Subject: This patch adds a new package "flock" that allows to manage file
 locks from shell scripts. It provides more functionality than the busybox
 "lock" command, i.e. locking existing file descriptors and non-blocking
 operation.

SVN-Revision: 15669
---
 package/util-linux-ng/Makefile | 18 +++++++++++++++++-
 1 file changed, 17 insertions(+), 1 deletion(-)

diff --git a/package/util-linux-ng/Makefile b/package/util-linux-ng/Makefile
index 8f4ee9b189..56645f25a3 100644
--- a/package/util-linux-ng/Makefile
+++ b/package/util-linux-ng/Makefile
@@ -1,5 +1,5 @@
 #
-# Copyright (C) 2007-2008 OpenWrt.org
+# Copyright (C) 2007-2009 OpenWrt.org
 #
 # This is free software, licensed under the GNU General Public License v2.
 # See /LICENSE for more information.
@@ -88,11 +88,21 @@ define Package/hwclock/description
  This package contains a utility for managing the hardware clock.
 endef
 
+define Package/flock
+$(call Package/util-linux/Default)
+  TITLE:=Manage file locks from shell scripts
+endef
+
+define Package/flock/description
+  This package contains a utility for managing file locks from shell scripts.
+endef
+
 define Build/Compile
 	$(MAKE) -C $(PKG_BUILD_DIR)/disk-utils mkswap
 	$(MAKE) -C $(PKG_BUILD_DIR)/mount swapon losetup umount mount
 	$(MAKE) -C $(PKG_BUILD_DIR)/fdisk fdisk cfdisk
 	$(MAKE) -C $(PKG_BUILD_DIR)/hwclock hwclock
+	$(MAKE) -C $(PKG_BUILD_DIR)/sys-utils flock
 endef
 
 define Package/fdisk/install
@@ -126,9 +136,15 @@ define Package/hwclock/install
 	$(INSTALL_BIN) $(PKG_BUILD_DIR)/hwclock/hwclock $(1)/sbin/
 endef
 
+define Package/flock/install
+	$(INSTALL_DIR) $(1)/usr/bin
+	$(INSTALL_BIN) $(PKG_BUILD_DIR)/sys-utils/flock $(1)/usr/bin/
+endef
+
 $(eval $(call BuildPackage,fdisk))
 $(eval $(call BuildPackage,cfdisk))
 $(eval $(call BuildPackage,losetup))
 $(eval $(call BuildPackage,mount-utils))
 $(eval $(call BuildPackage,swap-utils))
 $(eval $(call BuildPackage,hwclock))
+$(eval $(call BuildPackage,flock))
-- 
cgit v1.2.3