From 9284956ad87d5ed67fbf7246ea68a4f9544312f3 Mon Sep 17 00:00:00 2001
From: John Crispin <john@openwrt.org>
Date: Thu, 19 Jun 2014 14:13:07 +0000
Subject: ramips: cleanup some rt305x profiles

move both asus boards to asus.mk
rename HW5503G profile to HW550-3G to match name in image/Makefile
(fixes #16599)

Signed-off-by: Daniel Golle <daniel@makrotopia.org>

SVN-Revision: 41271
---
 target/linux/ramips/rt305x/profiles/asus.mk        | 27 ++++++++++++++++++++++
 target/linux/ramips/rt305x/profiles/aztech.mk      |  6 ++---
 .../rt305x/profiles/n10-plus.mk    (revision 0)    | 17 --------------
 target/linux/ramips/rt305x/profiles/n13u.mk        | 17 --------------
 4 files changed, 30 insertions(+), 37 deletions(-)
 create mode 100644 target/linux/ramips/rt305x/profiles/asus.mk
 delete mode 100644 target/linux/ramips/rt305x/profiles/n10-plus.mk    (revision 0)
 delete mode 100644 target/linux/ramips/rt305x/profiles/n13u.mk

diff --git a/target/linux/ramips/rt305x/profiles/asus.mk b/target/linux/ramips/rt305x/profiles/asus.mk
new file mode 100644
index 0000000000..fcf4aa4759
--- /dev/null
+++ b/target/linux/ramips/rt305x/profiles/asus.mk
@@ -0,0 +1,27 @@
+#
+# Copyright (C) 2014 OpenWrt.org
+#
+# This is free software, licensed under the GNU General Public License v2.
+# See /LICENSE for more information.
+#
+
+define Profile/RT-N10-PLUS
+	NAME:=Asus RT-N10+
+	PACKAGES:=kmod-leds-gpio wpa
+endef
+
+define Profile/RT-N10-PLUS/Description
+	Package set for Asus RT-N10+.
+endef
+
+define Profile/RT-N13U
+	NAME:=Asus RT-N13U
+	PACKAGES:=kmod-leds-gpio kmod-rt2800-pci wpad-mini kmod-usb-rt305x-dwc_otg
+endef
+
+define Profile/RT-N13U/Description
+	Package set for Asus RT-N13U.
+endef
+
+$(eval $(call Profile,RT-N10-PLUS))
+$(eval $(call Profile,RT-N13U))
diff --git a/target/linux/ramips/rt305x/profiles/aztech.mk b/target/linux/ramips/rt305x/profiles/aztech.mk
index ab2d8cba2f..63e5d5e294 100644
--- a/target/linux/ramips/rt305x/profiles/aztech.mk
+++ b/target/linux/ramips/rt305x/profiles/aztech.mk
@@ -5,15 +5,15 @@
 # See /LICENSE for more information.
 #
 
-define Profile/HW5503G
+define Profile/HW550-3G
 	NAME:=Aztech HW550-3G
 	PACKAGES:=\
 		kmod-usb-core kmod-usb-rt305x-dwc_otg \
 		kmod-ledtrig-usbdev
 endef
 
-define Profile/HW5503G/Description
+define Profile/HW550-3G/Description
 	Package set for Aztech HW550-3G
 endef
 
-$(eval $(call Profile,HW5503G))
+$(eval $(call Profile,HW550-3G))
diff --git a/target/linux/ramips/rt305x/profiles/n10-plus.mk    (revision 0) b/target/linux/ramips/rt305x/profiles/n10-plus.mk    (revision 0)
deleted file mode 100644
index 8c122f75bb..0000000000
--- a/target/linux/ramips/rt305x/profiles/n10-plus.mk    (revision 0)	
+++ /dev/null
@@ -1,17 +0,0 @@
-#
-# Copyright (C) 2014 OpenWrt.org
-#
-# This is free software, licensed under the GNU General Public License v2.
-# See /LICENSE for more information.
-#
-
-define Profile/RT-N10-PLUS
-    NAME:=Asus RT-N10+
-    PACKAGES:=kmod-leds-gpio wpa
-endef
-
-define Profile/RT-N10-PLUS/Description
-    Package set for Asus RT-N10+.
-endef
-
-$(eval $(call Profile,RT-N10-PLUS))
diff --git a/target/linux/ramips/rt305x/profiles/n13u.mk b/target/linux/ramips/rt305x/profiles/n13u.mk
deleted file mode 100644
index 6c81722efe..0000000000
--- a/target/linux/ramips/rt305x/profiles/n13u.mk
+++ /dev/null
@@ -1,17 +0,0 @@
-#
-# Copyright (C) 2010 OpenWrt.org
-#
-# This is free software, licensed under the GNU General Public License v2.
-# See /LICENSE for more information.
-#
-
-define Profile/RT-N13U
-	NAME:=Asus RT-N13U
-	PACKAGES:=kmod-leds-gpio kmod-rt2800-pci wpad-mini kmod-usb-rt305x-dwc_otg
-endef
-
-define Profile/RT-N13U/Description
-	Package set for Asus RT-N13U.
-endef
-
-$(eval $(call Profile,RT-N13U))
-- 
cgit v1.2.3