From 8e31c2a97bcd11396c4f29c9a9f64d5ec126c11c Mon Sep 17 00:00:00 2001
From: Felix Fietkau <nbd@openwrt.org>
Date: Sat, 11 Jun 2011 13:25:00 +0000
Subject: toolchain/gdb: fix compile for powerpc targets, refresh patch

git-svn-id: svn://svn.openwrt.org/openwrt/trunk@27155 3c298f89-4303-0410-b956-a3cf2f4a3e73
---
 toolchain/gdb/patches/100-ppc_compile_fix.patch          | 11 +++++++++++
 .../gdb/patches/600-fix-compile-flag-mismatch.patch      | 16 ++++++----------
 2 files changed, 17 insertions(+), 10 deletions(-)
 create mode 100644 toolchain/gdb/patches/100-ppc_compile_fix.patch

diff --git a/toolchain/gdb/patches/100-ppc_compile_fix.patch b/toolchain/gdb/patches/100-ppc_compile_fix.patch
new file mode 100644
index 0000000000..4c5cb4efd9
--- /dev/null
+++ b/toolchain/gdb/patches/100-ppc_compile_fix.patch
@@ -0,0 +1,11 @@
+--- a/sim/ppc/Makefile.in
++++ b/sim/ppc/Makefile.in
+@@ -551,7 +551,7 @@ PACKAGE_SRC = @sim_pk_src@
+ PACKAGE_OBJ = @sim_pk_obj@
+ 
+ 
+-psim: $(TARGETLIB) main.o $(LIBIBERTY_LIB) $(BFD_LIB) $(LIBS) $(LIBINTL_DEP)
++psim: $(TARGETLIB) main.o $(LIBIBERTY_LIB) $(BFD_LIB) $(LIBINTL_DEP)
+ 	$(CC) $(CFLAGS) $(SIM_CFLAGS) $(LDFLAGS) -o psim$(EXEEXT) main.o $(TARGETLIB) $(BFD_LIB) $(LIBINTL) $(LIBIBERTY_LIB) $(LIBS)
+ 
+ run: psim
diff --git a/toolchain/gdb/patches/600-fix-compile-flag-mismatch.patch b/toolchain/gdb/patches/600-fix-compile-flag-mismatch.patch
index 124b3cce2c..089ab8c5a5 100644
--- a/toolchain/gdb/patches/600-fix-compile-flag-mismatch.patch
+++ b/toolchain/gdb/patches/600-fix-compile-flag-mismatch.patch
@@ -1,7 +1,5 @@
-Index: openwrt/dl/gdb-7.2/gdb/configure
-===================================================================
---- gdb-7.2/gdb/configure
-+++ gdb-7.2/gdb/configure
+--- a/gdb/configure
++++ b/gdb/configure
 @@ -988,7 +988,7 @@ CPP
  YACC
  YFLAGS
@@ -11,7 +9,7 @@ Index: openwrt/dl/gdb-7.2/gdb/configure
  gdbtk
  multi-ice
  gdbserver'
-@@ -7880,7 +7880,7 @@ fi
+@@ -7881,7 +7881,7 @@ fi
  
  
  
@@ -20,11 +18,9 @@ Index: openwrt/dl/gdb-7.2/gdb/configure
  
  
  # Check whether to support alternative target configurations
-Index: openwrt/dl/gdb-7.2/gdb/gdbserver/configure
-===================================================================
---- gdb-7.2/gdb/gdbserver/configure
-+++ gdb-7.2/gdb/gdbserver/configure
-@@ -2151,7 +2151,7 @@ $as_echo "$as_me: error: \`$ac_var' was 
+--- a/gdb/gdbserver/configure
++++ b/gdb/gdbserver/configure
+@@ -2152,7 +2152,7 @@ $as_echo "$as_me: error: \`$ac_var' was 
        ac_cache_corrupted=: ;;
      ,);;
      *)
-- 
cgit v1.2.3