From 81a3955189c4f8cdb404c161809e710b721afba7 Mon Sep 17 00:00:00 2001
From: Florian Fainelli <florian@openwrt.org>
Date: Thu, 29 Oct 2009 10:55:52 +0000
Subject: fix build failure on vmlinux.lds with 2.6.31 (#6052)

SVN-Revision: 18199
---
 .../patches-2.6.31/032-mips_vmlinux_lds.patch      | 37 ++++++++++++++++++++++
 1 file changed, 37 insertions(+)
 create mode 100644 target/linux/generic-2.6/patches-2.6.31/032-mips_vmlinux_lds.patch

diff --git a/target/linux/generic-2.6/patches-2.6.31/032-mips_vmlinux_lds.patch b/target/linux/generic-2.6/patches-2.6.31/032-mips_vmlinux_lds.patch
new file mode 100644
index 0000000000..cfe2a4d6c1
--- /dev/null
+++ b/target/linux/generic-2.6/patches-2.6.31/032-mips_vmlinux_lds.patch
@@ -0,0 +1,37 @@
+diff -Nru linux-2.6.31.5/arch/mips/kernel/Makefile linux-2.6.31.5.new/arch/mips/kernel/Makefile
+--- linux-2.6.31.5/arch/mips/kernel/Makefile	2009-10-25 12:35:46.137368384 +0200
++++ linux-2.6.31.5.new/arch/mips/kernel/Makefile	2009-10-25 15:24:04.713493469 +0200
+@@ -2,6 +2,8 @@
+ # Makefile for the Linux/MIPS kernel.
+ #
+ 
++CPPFLAGS_vmlinux.lds := $(KBUILD_CFLAGS) $(EXTRA_LDSFLAGS)
++
+ extra-y		:= head.o init_task.o vmlinux.lds
+ 
+ obj-y		+= cpu-probe.o branch.o entry.o genex.o irq.o process.o \
+diff -Nru linux-2.6.31.5/arch/mips/kernel/vmlinux.lds.S linux-2.6.31.5.new/arch/mips/kernel/vmlinux.lds.S
+--- linux-2.6.31.5/arch/mips/kernel/vmlinux.lds.S	2009-10-23 01:57:56.000000000 +0300
++++ linux-2.6.31.5.new/arch/mips/kernel/vmlinux.lds.S	2009-10-25 15:26:11.631618513 +0200
+@@ -10,15 +10,15 @@
+ 	note PT_NOTE FLAGS(4);	/* R__ */
+ }
+ 
+-ifdef CONFIG_32BIT
+-	ifdef CONFIG_CPU_LITTLE_ENDIAN
++#ifdef CONFIG_32BIT
++	#ifdef CONFIG_CPU_LITTLE_ENDIAN
+ 		jiffies  = jiffies_64;
+-	else
++	#else
+ 		jiffies  = jiffies_64 + 4;
+-	endif
+-else
++	#endif
++#else
+ 	jiffies  = jiffies_64;
+-endif
++#endif
+ 
+ SECTIONS
+ {
-- 
cgit v1.2.3