From 68b5c56aeddd697c6db50a28f7ee0e40bff907a1 Mon Sep 17 00:00:00 2001
From: Gabor Juhos <juhosg@openwrt.org>
Date: Mon, 5 Dec 2011 17:27:00 +0000
Subject: include/package-ipkg.mk: don't add vi backup files to packages

Also remove trailing whitespaces.

git-svn-id: svn://svn.openwrt.org/openwrt/trunk@29449 3c298f89-4303-0410-b956-a3cf2f4a3e73
---
 include/package-ipkg.mk | 6 +++---
 1 file changed, 3 insertions(+), 3 deletions(-)

diff --git a/include/package-ipkg.mk b/include/package-ipkg.mk
index 9eec4f26e9..50d18e04de 100644
--- a/include/package-ipkg.mk
+++ b/include/package-ipkg.mk
@@ -1,4 +1,4 @@
-# 
+#
 # Copyright (C) 2006,2007 OpenWrt.org
 #
 # This is free software, licensed under the GNU General Public License v2.
@@ -71,7 +71,7 @@ ifeq ($(DUMP),)
     endif
 
     IDEPEND_$(1):=$$(call filter_deps,$$(DEPENDS))
-  
+
     $(eval $(call BuildIPKGVariable,$(1),conffiles))
     $(eval $(call BuildIPKGVariable,$(1),preinst))
     $(eval $(call BuildIPKGVariable,$(1),postinst))
@@ -91,7 +91,7 @@ ifeq ($(DUMP),)
 	@rm -rf $(PACKAGE_DIR)/$(1)_* $$(IDIR_$(1))
 	mkdir -p $(PACKAGE_DIR) $$(IDIR_$(1))/CONTROL
 	$(call Package/$(1)/install,$$(IDIR_$(1)))
-	-find $$(IDIR_$(1)) -name 'CVS' -o -name '.svn' -o -name '.#*' | $(XARGS) rm -rf
+	-find $$(IDIR_$(1)) -name 'CVS' -o -name '.svn' -o -name '.#*' -o name '*~'| $(XARGS) rm -rf
 	$(RSTRIP) $$(IDIR_$(1))
 	( \
 		echo "Package: $(1)"; \
-- 
cgit v1.2.3