From 397365a2cbcd22ca2b4b1dba8b365b3587e4547d Mon Sep 17 00:00:00 2001
From: Gabor Juhos <juhosg@openwrt.org>
Date: Sun, 4 Jan 2009 19:06:00 +0000
Subject: [ar71xx] add preliminary support for the Atheros PB42 board

git-svn-id: svn://svn.openwrt.org/openwrt/trunk@13860 3c298f89-4303-0410-b956-a3cf2f4a3e73
---
 target/linux/ar71xx/config-2.6.26                  |  3 +-
 target/linux/ar71xx/config-2.6.27                  |  3 +-
 target/linux/ar71xx/config-2.6.28                  |  3 +-
 .../arch/mips/include/asm/mach-ar71xx/ar71xx.h     |  2 +
 target/linux/ar71xx/files/arch/mips/ar71xx/Kconfig |  4 ++
 .../linux/ar71xx/files/arch/mips/ar71xx/Makefile   |  3 +-
 .../ar71xx/files/arch/mips/ar71xx/mach-pb42.c      | 68 ++++++++++++++++++++++
 target/linux/ar71xx/files/arch/mips/ar71xx/prom.c  |  3 +
 .../files/include/asm-mips/mach-ar71xx/ar71xx.h    |  1 +
 9 files changed, 86 insertions(+), 4 deletions(-)
 create mode 100644 target/linux/ar71xx/files/arch/mips/ar71xx/mach-pb42.c

diff --git a/target/linux/ar71xx/config-2.6.26 b/target/linux/ar71xx/config-2.6.26
index 4f6340581f..518f2975f3 100644
--- a/target/linux/ar71xx/config-2.6.26
+++ b/target/linux/ar71xx/config-2.6.26
@@ -7,11 +7,12 @@ CONFIG_AG71XX=y
 CONFIG_AR71XX_MACH_AP83=y
 CONFIG_AR71XX_MACH_AW_NR580=y
 CONFIG_AR71XX_MACH_GENERIC=y
+CONFIG_AR71XX_MACH_PB42=y
 CONFIG_AR71XX_MACH_RB_4XX=y
 CONFIG_AR71XX_MACH_TEW_632BRP=y
 CONFIG_AR71XX_MACH_UBNT=y
-CONFIG_AR71XX_MACH_WP543=y
 CONFIG_AR71XX_MACH_WNR2000=y
+CONFIG_AR71XX_MACH_WP543=y
 CONFIG_AR71XX_WDT=y
 # CONFIG_ARCH_HAS_ILOG2_U32 is not set
 # CONFIG_ARCH_HAS_ILOG2_U64 is not set
diff --git a/target/linux/ar71xx/config-2.6.27 b/target/linux/ar71xx/config-2.6.27
index 15fb517b7b..502f458ed6 100644
--- a/target/linux/ar71xx/config-2.6.27
+++ b/target/linux/ar71xx/config-2.6.27
@@ -7,11 +7,12 @@ CONFIG_AG71XX=y
 CONFIG_AR71XX_MACH_AP83=y
 CONFIG_AR71XX_MACH_AW_NR580=y
 CONFIG_AR71XX_MACH_GENERIC=y
+CONFIG_AR71XX_MACH_PB42=y
 CONFIG_AR71XX_MACH_RB_4XX=y
 CONFIG_AR71XX_MACH_TEW_632BRP=y
 CONFIG_AR71XX_MACH_UBNT=y
-CONFIG_AR71XX_MACH_WP543=y
 CONFIG_AR71XX_MACH_WNR2000=y
+CONFIG_AR71XX_MACH_WP543=y
 CONFIG_AR71XX_WDT=y
 # CONFIG_ARCH_HAS_ILOG2_U32 is not set
 # CONFIG_ARCH_HAS_ILOG2_U64 is not set
diff --git a/target/linux/ar71xx/config-2.6.28 b/target/linux/ar71xx/config-2.6.28
index ef6b85272d..522f1c7e15 100644
--- a/target/linux/ar71xx/config-2.6.28
+++ b/target/linux/ar71xx/config-2.6.28
@@ -7,11 +7,12 @@ CONFIG_AG71XX=y
 CONFIG_AR71XX_MACH_AP83=y
 CONFIG_AR71XX_MACH_AW_NR580=y
 CONFIG_AR71XX_MACH_GENERIC=y
+CONFIG_AR71XX_MACH_PB42=y
 CONFIG_AR71XX_MACH_RB_4XX=y
 CONFIG_AR71XX_MACH_TEW_632BRP=y
 CONFIG_AR71XX_MACH_UBNT=y
-CONFIG_AR71XX_MACH_WP543=y
 CONFIG_AR71XX_MACH_WNR2000=y
+CONFIG_AR71XX_MACH_WP543=y
 CONFIG_AR71XX_WDT=y
 # CONFIG_ARCH_HAS_ILOG2_U32 is not set
 # CONFIG_ARCH_HAS_ILOG2_U64 is not set
diff --git a/target/linux/ar71xx/files-2.6.28/arch/mips/include/asm/mach-ar71xx/ar71xx.h b/target/linux/ar71xx/files-2.6.28/arch/mips/include/asm/mach-ar71xx/ar71xx.h
index 64fe5555c7..09ffdfe07f 100644
--- a/target/linux/ar71xx/files-2.6.28/arch/mips/include/asm/mach-ar71xx/ar71xx.h
+++ b/target/linux/ar71xx/files-2.6.28/arch/mips/include/asm/mach-ar71xx/ar71xx.h
@@ -120,6 +120,8 @@ extern unsigned long ar71xx_mach_type;
 #define AR71XX_MACH_UBNT_RS	9	/* Ubiquiti RouterStation */
 #define AR71XX_MACH_UBNT_LSX	10	/* Ubiquiti LSX */
 #define AR71XX_MACH_WNR2000	11	/* NETGEAR WNR2000 */
+#define AR71XX_MACH_PB42	12	/* Atheros PB42 */
+
 
 /*
  * PLL block
diff --git a/target/linux/ar71xx/files/arch/mips/ar71xx/Kconfig b/target/linux/ar71xx/files/arch/mips/ar71xx/Kconfig
index e10a7c9572..d8e22470f4 100644
--- a/target/linux/ar71xx/files/arch/mips/ar71xx/Kconfig
+++ b/target/linux/ar71xx/files/arch/mips/ar71xx/Kconfig
@@ -10,6 +10,10 @@ config AR71XX_MACH_AP83
 	bool "Atheros AP83 board support"
 	default y
 
+config AR71XX_MACH_PB42
+	bool "Atheros PB42 board support"
+	default y
+
 config AR71XX_MACH_AW_NR580
 	bool "AzureWave AW-NR580 board support"
 	default y
diff --git a/target/linux/ar71xx/files/arch/mips/ar71xx/Makefile b/target/linux/ar71xx/files/arch/mips/ar71xx/Makefile
index 588d23f6a9..b634e36d68 100644
--- a/target/linux/ar71xx/files/arch/mips/ar71xx/Makefile
+++ b/target/linux/ar71xx/files/arch/mips/ar71xx/Makefile
@@ -13,8 +13,9 @@ obj-y	:= prom.o irq.o setup.o platform.o gpio.o ar71xx.o
 obj-$(CONFIG_AR71XX_MACH_AP83)		+= mach-ap83.o
 obj-$(CONFIG_AR71XX_MACH_AW_NR580)	+= mach-aw-nr580.o
 obj-$(CONFIG_AR71XX_MACH_GENERIC)	+= mach-generic.o
+obj-$(CONFIG_AR71XX_MACH_PB42)		+= mach-pb42.o
 obj-$(CONFIG_AR71XX_MACH_RB_4XX)	+= mach-rb-4xx.o
 obj-$(CONFIG_AR71XX_MACH_TEW_632BRP)	+= mach-tew-632brp.o
 obj-$(CONFIG_AR71XX_MACH_UBNT)		+= mach-ubnt.o
-obj-$(CONFIG_AR71XX_MACH_WP543)		+= mach-wp543.o
 obj-$(CONFIG_AR71XX_MACH_WNR2000)	+= mach-wnr2000.o
+obj-$(CONFIG_AR71XX_MACH_WP543)		+= mach-wp543.o
diff --git a/target/linux/ar71xx/files/arch/mips/ar71xx/mach-pb42.c b/target/linux/ar71xx/files/arch/mips/ar71xx/mach-pb42.c
new file mode 100644
index 0000000000..0379692d7a
--- /dev/null
+++ b/target/linux/ar71xx/files/arch/mips/ar71xx/mach-pb42.c
@@ -0,0 +1,68 @@
+/*
+ *  Atheros PB42 board support
+ *
+ *  Copyright (C) 2008 Gabor Juhos <juhosg@openwrt.org>
+ *  Copyright (C) 2008 Imre Kaloz <kaloz@openwrt.org>
+ *
+ *  This program is free software; you can redistribute it and/or modify it
+ *  under the terms of the GNU General Public License version 2 as published
+ *  by the Free Software Foundation.
+ */
+
+#include <linux/init.h>
+#include <linux/platform_device.h>
+#include <linux/spi/spi.h>
+#include <linux/spi/flash.h>
+
+#include <asm/mips_machine.h>
+#include <asm/mach-ar71xx/ar71xx.h>
+#include <asm/mach-ar71xx/pci.h>
+#include <asm/mach-ar71xx/platform.h>
+
+static struct spi_board_info pb42_spi_info[] = {
+	{
+		.bus_num	= 0,
+		.chip_select	= 0,
+		.max_speed_hz	= 25000000,
+		.modalias	= "m25p80",
+	}
+};
+
+static struct ar71xx_pci_irq pb42_pci_irqs[] __initdata = {
+	{
+		.slot	= 0,
+		.pin	= 1,
+		.irq	= AR71XX_PCI_IRQ_DEV0,
+	}, {
+		.slot	= 1,
+		.pin	= 1,
+		.irq	= AR71XX_PCI_IRQ_DEV1,
+	}, {
+		.slot	= 2,
+		.pin	= 1,
+		.irq	= AR71XX_PCI_IRQ_DEV2,
+	}
+};
+
+static void __init pb42_init(void)
+{
+	ar71xx_add_device_spi(NULL, pb42_spi_info,
+				ARRAY_SIZE(pb42_spi_info));
+
+	ar71xx_add_device_mdio(0xffe0ffff);
+
+	ar71xx_eth0_data.phy_if_mode = PHY_INTERFACE_MODE_MII;
+	ar71xx_eth0_data.phy_mask = 0x000f0000;
+
+	ar71xx_eth1_data.phy_if_mode = PHY_INTERFACE_MODE_RMII;
+	ar71xx_eth1_data.phy_mask = 0x00100000;
+
+	ar71xx_add_device_eth(0);
+	ar71xx_add_device_eth(1);
+
+	ar71xx_add_device_usb();
+
+	ar71xx_pci_init(ARRAY_SIZE(pb42_pci_irqs), pb42_pci_irqs);
+}
+
+MIPS_MACHINE(AR71XX_MACH_PB42, "Atheros PB42", pb42_init);
diff --git a/target/linux/ar71xx/files/arch/mips/ar71xx/prom.c b/target/linux/ar71xx/files/arch/mips/ar71xx/prom.c
index f9984ca1c4..bb6a112a23 100644
--- a/target/linux/ar71xx/files/arch/mips/ar71xx/prom.c
+++ b/target/linux/ar71xx/files/arch/mips/ar71xx/prom.c
@@ -61,6 +61,9 @@ static struct board_rec boards[] __initdata = {
 	}, {
 		.name		= "WNR2000",
 		.mach_type	= AR71XX_MACH_WNR2000,
+	}, {
+		.name		= "PB42",
+		.mach_type	= AR71XX_MACH_PB42,
 	}
 };
 
diff --git a/target/linux/ar71xx/files/include/asm-mips/mach-ar71xx/ar71xx.h b/target/linux/ar71xx/files/include/asm-mips/mach-ar71xx/ar71xx.h
index 64fe5555c7..3895b21e4c 100644
--- a/target/linux/ar71xx/files/include/asm-mips/mach-ar71xx/ar71xx.h
+++ b/target/linux/ar71xx/files/include/asm-mips/mach-ar71xx/ar71xx.h
@@ -120,6 +120,7 @@ extern unsigned long ar71xx_mach_type;
 #define AR71XX_MACH_UBNT_RS	9	/* Ubiquiti RouterStation */
 #define AR71XX_MACH_UBNT_LSX	10	/* Ubiquiti LSX */
 #define AR71XX_MACH_WNR2000	11	/* NETGEAR WNR2000 */
+#define AR71XX_MACH_PB42	12	/* Atheros PB42 */
 
 /*
  * PLL block
-- 
cgit v1.2.3