From 2112af299f2b1d2f6e17845d99a0cd9807e03e38 Mon Sep 17 00:00:00 2001
From: Felix Fietkau <nbd@openwrt.org>
Date: Tue, 25 Dec 2007 00:27:32 +0000
Subject: add automake to tools/

SVN-Revision: 9901
---
 tools/Makefile          |  2 +-
 tools/automake/Makefile | 38 ++++++++++++++++++++++++++++++++++++++
 2 files changed, 39 insertions(+), 1 deletion(-)
 create mode 100644 tools/automake/Makefile

diff --git a/tools/Makefile b/tools/Makefile
index fc3b2e175d..83244fa609 100644
--- a/tools/Makefile
+++ b/tools/Makefile
@@ -9,7 +9,7 @@
 curdir:=tools
 
 # subdirectories to descend into
-$(curdir)/builddirs := sed sstrip ipkg-utils genext2fs squashfs mtd-utils lzma mkimage firmware-utils patch-cmdline pkg-config $(if $(CONFIG_CCACHE),ccache)
+$(curdir)/builddirs := sed sstrip ipkg-utils genext2fs squashfs mtd-utils lzma mkimage firmware-utils patch-cmdline pkg-config automake $(if $(CONFIG_CCACHE),ccache)
 
 # builddir dependencies
 $(curdir)/squashfs/compile := $(curdir)/lzma/install
diff --git a/tools/automake/Makefile b/tools/automake/Makefile
new file mode 100644
index 0000000000..cf39cbda8b
--- /dev/null
+++ b/tools/automake/Makefile
@@ -0,0 +1,38 @@
+# 
+# Copyright (C) 2006 OpenWrt.org
+#
+# This is free software, licensed under the GNU General Public License v2.
+# See /LICENSE for more information.
+#
+include $(TOPDIR)/rules.mk
+
+PKG_NAME:=automake
+PKG_VERSION:=1.9.6
+
+PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.bz2
+PKG_SOURCE_URL:=@GNU/automake
+PKG_MD5SUM:=c11b8100bb311492d8220378fd8bf9e0
+
+include $(INCLUDE_DIR)/host-build.mk
+
+define Build/Configure
+	$(call Build/Configure/Default,\
+		--datarootdir=$(STAGING_DIR_HOST)/share \
+	)
+endef
+
+define Build/Compile
+	$(MAKE) -C $(PKG_BUILD_DIR)
+endef
+
+define Build/Install
+	$(MAKE) -C $(PKG_BUILD_DIR) install
+endef
+
+define Build/Clean
+	$(MAKE) -C $(PKG_BUILD_DIR) uninstall
+	$(MAKE) -C $(PKG_BUILD_DIR) clean
+	$(call Build/Clean/Default)
+endef
+
+$(eval $(call HostBuild))
-- 
cgit v1.2.3