From 1119b22e5712646cf481a126d8cce9e1569a55b1 Mon Sep 17 00:00:00 2001
From: Mirko Vogt <mirko@openwrt.org>
Date: Fri, 17 Jun 2011 22:51:20 +0000
Subject: [package/hotplug2] link against 'libbsd' when using glibc

git-svn-id: svn://svn.openwrt.org/openwrt/trunk@27209 3c298f89-4303-0410-b956-a3cf2f4a3e73
---
 package/hotplug2/Makefile | 4 ++--
 1 file changed, 2 insertions(+), 2 deletions(-)

diff --git a/package/hotplug2/Makefile b/package/hotplug2/Makefile
index 9625ba27f9..699976e8a9 100644
--- a/package/hotplug2/Makefile
+++ b/package/hotplug2/Makefile
@@ -28,7 +28,7 @@ define Package/hotplug2
   VERSION:=1.0-beta-$(PKG_RELEASE)
   TITLE:=Version 1.0 Dynamic device management subsystem for embedded systems
   URL:=http://isteve.bofh.cz/~isteve/hotplug2/
-  DEPENDS:=+USE_EGLIBC:libbsd
+  DEPENDS:=+USE_EGLIBC:libbsd +USE_GLIBC:libbsd
 endef
 
 define Package/hotplug2/description
@@ -45,7 +45,7 @@ MAKE_FLAGS += \
 	COPTS="$(TARGET_CFLAGS)" \
 	STATIC_WORKER="fork"
 
-ifneq ($(CONFIG_USE_EGLIBC),)
+ifneq ($(CONFIG_USE_EGLIBC)$(CONFIG_USE_GLIBC),)
   TARGET_LDFLAGS += -lbsd
 endif
 
-- 
cgit v1.2.3