aboutsummaryrefslogtreecommitdiffstats
path: root/tools/bc/patches
diff options
context:
space:
mode:
Diffstat (limited to 'tools/bc/patches')
-rw-r--r--tools/bc/patches/001-no_doc.patch24
-rw-r--r--tools/bc/patches/002-fix-libmath.patch32
-rw-r--r--tools/bc/patches/003-bc-fix-hang.patch11
3 files changed, 54 insertions, 13 deletions
diff --git a/tools/bc/patches/001-no_doc.patch b/tools/bc/patches/001-no_doc.patch
index 50deee8c89..119f111f49 100644
--- a/tools/bc/patches/001-no_doc.patch
+++ b/tools/bc/patches/001-no_doc.patch
@@ -1,6 +1,5 @@
-diff -urN bc-1.06.95/Makefile.am bc-1.06.95.new/Makefile.am
---- bc-1.06.95/Makefile.am 2005-05-27 01:05:41.000000000 +0100
-+++ bc-1.06.95.new/Makefile.am 2013-07-09 09:33:31.521490710 +0100
+--- a/Makefile.am
++++ b/Makefile.am
@@ -1,6 +1,6 @@
## Process this file with automake to produce Makefile.in
@@ -8,16 +7,15 @@ diff -urN bc-1.06.95/Makefile.am bc-1.06.95.new/Makefile.am
+SUBDIRS = lib bc dc
MAINTAINERCLEANFILES = aclocal.m4 config.h.in configure Makefile.in \
- stamp-h $(distdir).tar.gz h/number.h depcomp missing
-diff -urN bc-1.06.95/Makefile.in bc-1.06.95.new/Makefile.in
---- bc-1.06.95/Makefile.in 2006-09-05 03:39:30.000000000 +0100
-+++ bc-1.06.95.new/Makefile.in 2013-07-09 09:33:28.565490767 +0100
-@@ -149,7 +149,7 @@
- sharedstatedir = @sharedstatedir@
- sysconfdir = @sysconfdir@
- target_alias = @target_alias@
+ stamp-h $(distdir).tar.gz h/number.h depcomp missing \
+--- a/Makefile.in
++++ b/Makefile.in
+@@ -288,7 +288,7 @@ target_alias = @target_alias@
+ top_build_prefix = @top_build_prefix@
+ top_builddir = @top_builddir@
+ top_srcdir = @top_srcdir@
-SUBDIRS = lib bc dc doc
+SUBDIRS = lib bc dc
MAINTAINERCLEANFILES = aclocal.m4 config.h.in configure Makefile.in \
- stamp-h $(distdir).tar.gz h/number.h depcomp missing
-
+ stamp-h $(distdir).tar.gz h/number.h depcomp missing \
+ bc/libmath.h
diff --git a/tools/bc/patches/002-fix-libmath.patch b/tools/bc/patches/002-fix-libmath.patch
new file mode 100644
index 0000000000..1a8439542d
--- /dev/null
+++ b/tools/bc/patches/002-fix-libmath.patch
@@ -0,0 +1,32 @@
+--- a/bc/fix-libmath_h
++++ b/bc/fix-libmath_h
+@@ -1,9 +1,9 @@
+-ed libmath.h <<EOS-EOS
+-1,1s/^/{"/
+-1,\$s/\$/",/
+-2,\$s/^/"/
+-\$,\$d
+-\$,\$s/,\$/,0}/
+-w
+-q
+-EOS-EOS
++#! /bin/bash
++sed -e '1 s/^/{"/' \
++ -e 's/$/",/' \
++ -e '2,$ s/^/"/' \
++ -e '$ d' \
++ -i libmath.h
++
++sed -e '$ s/$/0}/' \
++ -i libmath.h
+--- a/configure
++++ b/configure
+@@ -5288,7 +5288,7 @@ case $bcle-$bcrl-$LEX in
+ ?-?-flex)
+ LEX="flex -I -8" ;;
+ ?-y-*)
+- as_fn_error $? "readline works only with flex." "$LINENO" 5 ;;
++ : ;; # as_fn_error $? "readline works only with flex." "$LINENO" 5 ;;
+ esac
+
+ case $LEX-`uname -s` in
diff --git a/tools/bc/patches/003-bc-fix-hang.patch b/tools/bc/patches/003-bc-fix-hang.patch
new file mode 100644
index 0000000000..ba297051e2
--- /dev/null
+++ b/tools/bc/patches/003-bc-fix-hang.patch
@@ -0,0 +1,11 @@
+--- a/bc/execute.c
++++ b/bc/execute.c
+@@ -595,7 +595,7 @@ input_char (void)
+ if (in_ch == '.' || in_ch == '+' || in_ch == '-')
+ return (in_ch);
+ if (in_ch <= ' ')
+- return (' ');
++ return (':');
+
+ return (':');
+ }