aboutsummaryrefslogtreecommitdiffstats
path: root/target
diff options
context:
space:
mode:
Diffstat (limited to 'target')
-rw-r--r--target/linux/armvirt/image/Makefile2
-rw-r--r--target/linux/armvirt/modules.mk11
2 files changed, 12 insertions, 1 deletions
diff --git a/target/linux/armvirt/image/Makefile b/target/linux/armvirt/image/Makefile
index 928ee3ce85..a4c0c17ec6 100644
--- a/target/linux/armvirt/image/Makefile
+++ b/target/linux/armvirt/image/Makefile
@@ -109,7 +109,7 @@ define Device/generic
kmod-i2c-mux-pca954x kmod-gpio-pca953x partx-utils kmod-wdt-sp805 \
kmod-mvneta kmod-mvpp2 kmod-fsl-dpaa1-net kmod-fsl-dpaa2-net \
kmod-fsl-enetc-net kmod-dwmac-imx kmod-fsl-fec kmod-thunderx-net \
- kmod-phy-aquantia kmod-phy-broadcom kmod-phy-marvell
+ kmod-dwmac-sun8i kmod-phy-aquantia kmod-phy-broadcom kmod-phy-marvell \
kmod-phy-marvell-10g kmod-atlantic
endef
TARGET_DEVICES += generic
diff --git a/target/linux/armvirt/modules.mk b/target/linux/armvirt/modules.mk
index e9555f0184..f94b25aad4 100644
--- a/target/linux/armvirt/modules.mk
+++ b/target/linux/armvirt/modules.mk
@@ -233,6 +233,17 @@ endef
$(eval $(call KernelPackage,dwmac-imx))
+define KernelPackage/dwmac-sun8i
+ SUBMENU=$(NETWORK_DEVICES_MENU)
+ TITLE:=Allwinner H3/A83T/A64 (sun8i) Ethernet
+ DEPENDS:=+kmod-stmmac-core +kmod-mdio-bus-mux
+ KCONFIG:=CONFIG_DWMAC_SUN8I
+ FILES=$(LINUX_DIR)/drivers/net/ethernet/stmicro/stmmac/dwmac-sun8i.ko
+ AUTOLOAD=$(call AutoLoad,45,dwmac-sun8i)
+endef
+
+$(eval $(call KernelPackage,dwmac-sun8i))
+
define KernelPackage/thunderx-net
SUBMENU:=$(NETWORK_DEVICES_MENU)
TITLE:=Marvell (Cavium) ThunderX/2 network drivers