aboutsummaryrefslogtreecommitdiffstats
path: root/target
diff options
context:
space:
mode:
Diffstat (limited to 'target')
-rw-r--r--target/linux/ath79/dts/ar9331_hiwifi_hc6361.dts156
-rw-r--r--target/linux/ath79/generic/base-files/etc/board.d/01_leds4
-rw-r--r--target/linux/ath79/generic/base-files/etc/board.d/02_network1
-rw-r--r--target/linux/ath79/image/generic.mk12
4 files changed, 173 insertions, 0 deletions
diff --git a/target/linux/ath79/dts/ar9331_hiwifi_hc6361.dts b/target/linux/ath79/dts/ar9331_hiwifi_hc6361.dts
new file mode 100644
index 0000000000..05d3f6730e
--- /dev/null
+++ b/target/linux/ath79/dts/ar9331_hiwifi_hc6361.dts
@@ -0,0 +1,156 @@
+// SPDX-License-Identifier: GPL-2.0-or-later OR MIT
+
+#include "ar9331.dtsi"
+
+#include <dt-bindings/gpio/gpio.h>
+#include <dt-bindings/input/input.h>
+
+/ {
+ model = "HiWiFi HC6361";
+ compatible = "hiwifi,hc6361", "qca,ar9331";
+
+ aliases {
+ serial0 = &uart;
+ led-boot = &led_system;
+ led-failsafe = &led_system;
+ led-running = &led_system;
+ led-upgrade = &led_system;
+ };
+
+ keys {
+ compatible = "gpio-keys";
+
+ reset {
+ label = "reset";
+ linux,code = <KEY_RESTART>;
+ gpios = <&gpio 11 GPIO_ACTIVE_LOW>;
+ debounce-interval = <60>;
+ };
+ };
+
+ leds {
+ compatible = "gpio-leds";
+
+ led_system: system {
+ label = "blue:system";
+ gpios = <&gpio 1 GPIO_ACTIVE_LOW>;
+ default-state = "on";
+ };
+ wlan {
+ label = "blue:wlan";
+ gpios = <&gpio 0 GPIO_ACTIVE_LOW>;
+ };
+ wan {
+ label = "blue:wan";
+ gpios = <&gpio 27 GPIO_ACTIVE_LOW>;
+ };
+ };
+
+ reg_usb_vbus: regulator {
+ compatible = "regulator-fixed";
+ regulator-name = "usb_vbus";
+ regulator-min-microvolt = <5000000>;
+ regulator-max-microvolt = <5000000>;
+ enable-active-high;
+ gpio = <&gpio 20 GPIO_ACTIVE_HIGH>;
+ };
+};
+
+&spi {
+ status = "okay";
+ num-cs = <1>;
+
+ flash@0 {
+ compatible = "jedec,spi-nor";
+ reg = <0>;
+ spi-max-frequency = <25000000>;
+
+ partitions {
+ compatible = "fixed-partitions";
+ #address-cells = <1>;
+ #size-cells = <1>;
+
+ uboot: partition@0 {
+ reg = <0x0 0x10000>;
+ label = "u-boot";
+ read-only;
+ };
+
+ bdinfo: partition@10000 {
+ reg = <0x10000 0x10000>;
+ label = "bdinfo";
+ read-only;
+ };
+
+ firmware: partition@20000 {
+ compatible = "denx,uimage";
+ reg = <0x20000 0xfc0000>;
+ label = "firmware";
+ };
+
+ backup: partition@fe0000 {
+ reg = <0xfe0000 0x10000>;
+ label = "backup";
+ read-only;
+ };
+
+ art: partition@ff0000 {
+ reg = <0xff0000 0x10000>;
+ label = "art";
+ read-only;
+ };
+ };
+ };
+};
+
+&gpio {
+ status = "okay";
+};
+
+&uart {
+ status = "okay";
+};
+
+&usb {
+ status = "okay";
+ dr_mode = "host";
+ vbus-supply = <&reg_usb_vbus>;
+};
+
+&usb_phy {
+ status = "okay";
+};
+
+&eth0 {
+ status = "okay";
+
+ nvmem-cells = <&macaddr_bdinfo_18a>;
+ nvmem-cell-names = "mac-address-ascii";
+ mac-address-increment = <1>;
+};
+
+&eth1 {
+ status = "okay";
+
+ nvmem-cells = <&macaddr_bdinfo_18a>;
+ nvmem-cell-names = "mac-address-ascii";
+};
+
+&wmac {
+ status = "okay";
+ mtd-cal-data = <&art 0x1000>;
+
+ nvmem-cells = <&macaddr_bdinfo_18a>;
+ nvmem-cell-names = "mac-address-ascii";
+ mac-address-increment = <2>;
+};
+
+&bdinfo {
+ compatible = "nvmem-cells";
+ #address-cells = <1>;
+ #size-cells = <1>;
+
+ macaddr_bdinfo_18a: macaddr@18a {
+ reg = <0x18a 0x11>;
+ };
+};
diff --git a/target/linux/ath79/generic/base-files/etc/board.d/01_leds b/target/linux/ath79/generic/base-files/etc/board.d/01_leds
index 12a54f3bd5..24beb7a361 100644
--- a/target/linux/ath79/generic/base-files/etc/board.d/01_leds
+++ b/target/linux/ath79/generic/base-files/etc/board.d/01_leds
@@ -250,6 +250,10 @@ joyit,jt-or750i|\
yuncore,xd3200)
ucidef_set_led_default "ath10k" "ath10k-disable" "ath10k-phy0" "0"
;;
+hiwifi,hc6361)
+ ucidef_set_led_netdev "wan" "WAN" "blue:wan" "eth1"
+ ucidef_set_led_wlan "wlan" "WLAN" "blue:wlan" "phy0tpt"
+ ;;
meraki,mr12|\
tplink,cpe210-v2|\
tplink,cpe210-v3)
diff --git a/target/linux/ath79/generic/base-files/etc/board.d/02_network b/target/linux/ath79/generic/base-files/etc/board.d/02_network
index 03e6434422..8f6063baef 100644
--- a/target/linux/ath79/generic/base-files/etc/board.d/02_network
+++ b/target/linux/ath79/generic/base-files/etc/board.d/02_network
@@ -504,6 +504,7 @@ ath79_setup_interfaces()
ucidef_add_switch "switch0" \
"0@eth0" "1:lan" "2:lan"
;;
+ hiwifi,hc6361|\
xiaomi,mi-router-4q|\
zbtlink,zbt-wd323)
ucidef_set_interface_wan "eth1"
diff --git a/target/linux/ath79/image/generic.mk b/target/linux/ath79/image/generic.mk
index dc85fb60bf..80a581a72c 100644
--- a/target/linux/ath79/image/generic.mk
+++ b/target/linux/ath79/image/generic.mk
@@ -1387,6 +1387,18 @@ define Device/hak5_wifi-pineapple-nano
endef
TARGET_DEVICES += hak5_wifi-pineapple-nano
+define Device/hiwifi_hc6361
+ SOC := ar9331
+ DEVICE_VENDOR := HiWiFi
+ DEVICE_MODEL := HC6361
+ DEVICE_PACKAGES := kmod-usb-core kmod-usb2 kmod-usb-chipidea2 kmod-usb-storage \
+ kmod-fs-ext4 kmod-nls-iso8859-1 e2fsprogs
+ BOARDNAME := HiWiFi-HC6361
+ KERNEL := kernel-bin | append-dtb | lzma | uImage lzma | pad-to $$(BLOCKSIZE)
+ IMAGE_SIZE := 16128k
+endef
+TARGET_DEVICES += hiwifi_hc6361
+
define Device/iodata_etg3-r
SOC := ar9342
DEVICE_VENDOR := I-O DATA