aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux/ath79/image/generic.mk
diff options
context:
space:
mode:
Diffstat (limited to 'target/linux/ath79/image/generic.mk')
-rw-r--r--target/linux/ath79/image/generic.mk16
1 files changed, 16 insertions, 0 deletions
diff --git a/target/linux/ath79/image/generic.mk b/target/linux/ath79/image/generic.mk
index a19412498a..59bc449f12 100644
--- a/target/linux/ath79/image/generic.mk
+++ b/target/linux/ath79/image/generic.mk
@@ -1324,6 +1324,22 @@ define Device/extreme-networks_ws-ap3805i
endef
TARGET_DEVICES += extreme-networks_ws-ap3805i
+define Device/fortinet_fap-221-b
+ $(Device/senao_loader_okli)
+ SOC := ar9344
+ DEVICE_VENDOR := Fortinet
+ DEVICE_MODEL := FAP-221-B
+ FACTORY_IMG_NAME := FP221B-9.99-AP-build999-999999-patch99
+ IMAGE_SIZE := 9216k
+ LOADER_FLASH_OFFS := 0x040000
+ IMAGE/factory.bin := append-kernel | pad-to $$$$(BLOCKSIZE) | \
+ append-rootfs | pad-rootfs | \
+ check-size | pad-to $$$$(IMAGE_SIZE) | \
+ append-loader-okli-uimage $(1) | pad-to 10944k | \
+ gzip-filename $$$$(FACTORY_IMG_NAME)
+endef
+TARGET_DEVICES += fortinet_fap-221-b
+
define Device/glinet_6408
$(Device/tplink-8mlzma)
SOC := ar9331