aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux/ath79/image/generic.mk
diff options
context:
space:
mode:
Diffstat (limited to 'target/linux/ath79/image/generic.mk')
-rw-r--r--target/linux/ath79/image/generic.mk16
1 files changed, 16 insertions, 0 deletions
diff --git a/target/linux/ath79/image/generic.mk b/target/linux/ath79/image/generic.mk
index 9c209b041f..d66684a124 100644
--- a/target/linux/ath79/image/generic.mk
+++ b/target/linux/ath79/image/generic.mk
@@ -1583,6 +1583,22 @@ define Device/joyit_jt-or750i
endef
TARGET_DEVICES += joyit_jt-or750i
+define Device/kuwfi_c910
+ $(Device/loader-okli-uimage)
+ SOC := qca9533
+ DEVICE_VENDOR := KuWFi
+ DEVICE_MODEL := C910
+ DEVICE_PACKAGES := kmod-usb2 kmod-usb-net-cdc-ether comgt-ncm
+ LOADER_FLASH_OFFS := 0x50000
+ KERNEL := kernel-bin | append-dtb | lzma | uImage lzma -M 0x4f4b4c49
+ IMAGE_SIZE := 15936k
+ IMAGES += factory.bin
+ IMAGE/factory.bin := append-kernel | pad-to $$$$(BLOCKSIZE) | \
+ append-rootfs | pad-rootfs | check-size | pad-to 14528k | \
+ append-loader-okli-uimage $(1) | pad-to 64k
+endef
+TARGET_DEVICES += kuwfi_c910
+
define Device/letv_lba-047-ch
$(Device/loader-okli-uimage)
SOC := qca9531