aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux/ath79/image/generic.mk
diff options
context:
space:
mode:
Diffstat (limited to 'target/linux/ath79/image/generic.mk')
-rw-r--r--target/linux/ath79/image/generic.mk15
1 files changed, 15 insertions, 0 deletions
diff --git a/target/linux/ath79/image/generic.mk b/target/linux/ath79/image/generic.mk
index 7072dc131e..fd63b623cd 100644
--- a/target/linux/ath79/image/generic.mk
+++ b/target/linux/ath79/image/generic.mk
@@ -2530,6 +2530,21 @@ define Device/ruckus_zf7025
endef
TARGET_DEVICES += ruckus_zf7025
+define Device/ruckus_gd11_common
+ $(Device/ruckus_common)
+ SOC := ar7161
+ IMAGE_SIZE := 15616k
+ BLOCKSIZE := 256k
+ DEVICE_PACKAGES := kmod-usb2 kmod-usb-chipidea2
+endef
+
+define Device/ruckus_zf7351
+ $(Device/ruckus_gd11_common)
+ DEVICE_MODEL := ZoneFlex 7351[-U]
+ DEVICE_PACKAGES += -swconfig
+endef
+TARGET_DEVICES += ruckus_zf7351
+
define Device/ruckus_zf73xx_common
$(Device/ruckus_common)
DEVICE_PACKAGES := -swconfig kmod-usb2 kmod-usb-chipidea2