aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux/ath79/image/common-netgear.mk
diff options
context:
space:
mode:
Diffstat (limited to 'target/linux/ath79/image/common-netgear.mk')
-rw-r--r--target/linux/ath79/image/common-netgear.mk22
1 files changed, 22 insertions, 0 deletions
diff --git a/target/linux/ath79/image/common-netgear.mk b/target/linux/ath79/image/common-netgear.mk
new file mode 100644
index 0000000000..ca4e005689
--- /dev/null
+++ b/target/linux/ath79/image/common-netgear.mk
@@ -0,0 +1,22 @@
+define Build/netgear-squashfs
+ rm -rf $@.fs $@.squashfs
+ mkdir -p $@.fs/image
+ cp $@ $@.fs/image/uImage
+ $(STAGING_DIR_HOST)/bin/mksquashfs-lzma \
+ $@.fs $@.squashfs -be \
+ -noappend -root-owned -b 65536 \
+ $(if $(SOURCE_DATE_EPOCH),-fixed-time $(SOURCE_DATE_EPOCH))
+
+ dd if=/dev/zero bs=1k count=1 >> $@.squashfs
+ mkimage \
+ -A mips -O linux -T filesystem -C none \
+ -M $(NETGEAR_KERNEL_MAGIC) \
+ -a 0xbf070000 -e 0xbf070000 \
+ -n 'MIPS $(VERSION_DIST) Linux-$(LINUX_VERSION)' \
+ -d $@.squashfs $@
+ rm -rf $@.squashfs $@.fs
+endef
+
+define Build/netgear-uImage
+ $(call Build/uImage,$(1) -M $(NETGEAR_KERNEL_MAGIC))
+endef