aboutsummaryrefslogtreecommitdiffstats
path: root/package
diff options
context:
space:
mode:
Diffstat (limited to 'package')
-rw-r--r--package/uhttpd/patches/100-json_c.patch15
1 files changed, 15 insertions, 0 deletions
diff --git a/package/uhttpd/patches/100-json_c.patch b/package/uhttpd/patches/100-json_c.patch
new file mode 100644
index 0000000000..06671fc513
--- /dev/null
+++ b/package/uhttpd/patches/100-json_c.patch
@@ -0,0 +1,15 @@
+--- a/CMakeLists.txt
++++ b/CMakeLists.txt
+@@ -62,10 +62,11 @@ ELSE()
+ MESSAGE(FATAL_ERROR "Invalid TLS provider option, use none|openssl|cyassl")
+ ENDIF()
+
++FIND_LIBRARY(json json-c json)
+ IF(UBUS_SUPPORT)
+ ADD_DEFINITIONS(-DHAVE_UBUS)
+ ADD_LIBRARY(uhttpd_ubus MODULE uhttpd-ubus.c)
+- TARGET_LINK_LIBRARIES(uhttpd_ubus ubox ubus json blobmsg_json)
++ TARGET_LINK_LIBRARIES(uhttpd_ubus ubox ubus ${json} blobmsg_json)
+ SET(PLUGINS ${PLUGINS} uhttpd_ubus)
+ ENDIF()
+