aboutsummaryrefslogtreecommitdiffstats
path: root/package/libs
diff options
context:
space:
mode:
Diffstat (limited to 'package/libs')
-rw-r--r--package/libs/libjson-c/Makefile6
-rw-r--r--package/libs/libjson-c/patches/001-dont-build-docs.patch8
-rw-r--r--package/libs/libjson-c/patches/010-clang.patch11
3 files changed, 7 insertions, 18 deletions
diff --git a/package/libs/libjson-c/Makefile b/package/libs/libjson-c/Makefile
index 0f13883a3b..2b90c27a4a 100644
--- a/package/libs/libjson-c/Makefile
+++ b/package/libs/libjson-c/Makefile
@@ -8,12 +8,12 @@
include $(TOPDIR)/rules.mk
PKG_NAME:=json-c
-PKG_VERSION:=0.15
-PKG_RELEASE:=2
+PKG_VERSION:=0.16
+PKG_RELEASE:=1
PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION)-nodoc.tar.gz
PKG_SOURCE_URL:=https://s3.amazonaws.com/json-c_releases/releases/
-PKG_HASH:=99bca4f944b8ced8ae0bbc6310d6a3528ca715e69541793a1ef51f8c5b4b0878
+PKG_HASH:=ac8a3dd6820daaca579b23fbc74664310fbc3d67f52f6707cda67d21dde5570f
PKG_MAINTAINER:=Felix Fietkau <nbd@nbd.name>
PKG_LICENSE:=MIT
diff --git a/package/libs/libjson-c/patches/001-dont-build-docs.patch b/package/libs/libjson-c/patches/001-dont-build-docs.patch
index 1aa0da4f59..f35da80724 100644
--- a/package/libs/libjson-c/patches/001-dont-build-docs.patch
+++ b/package/libs/libjson-c/patches/001-dont-build-docs.patch
@@ -1,11 +1,11 @@
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
-@@ -401,8 +401,6 @@ set(JSON_C_SOURCES
+@@ -433,8 +433,6 @@ configure_file(json.h.cmakein ${PROJECT_
include_directories(${PROJECT_SOURCE_DIR})
include_directories(${PROJECT_BINARY_DIR})
-add_subdirectory(doc)
-
- # uninstall
- add_custom_target(uninstall
- COMMAND cat ${PROJECT_BINARY_DIR}/install_manifest.txt | xargs rm
+ # "uninstall" custom target for make generators in unix like operating systems
+ # and if that target is not present
+ if (CMAKE_GENERATOR STREQUAL "Unix Makefiles")
diff --git a/package/libs/libjson-c/patches/010-clang.patch b/package/libs/libjson-c/patches/010-clang.patch
deleted file mode 100644
index 9ef73f1a82..0000000000
--- a/package/libs/libjson-c/patches/010-clang.patch
+++ /dev/null
@@ -1,11 +0,0 @@
---- a/CMakeLists.txt
-+++ b/CMakeLists.txt
-@@ -265,7 +265,7 @@ message(STATUS "Wrote ${PROJECT_BINARY_D
- configure_file(${PROJECT_SOURCE_DIR}/cmake/json_config.h.in ${PROJECT_BINARY_DIR}/json_config.h)
- message(STATUS "Wrote ${PROJECT_BINARY_DIR}/json_config.h")
-
--if ("${CMAKE_C_COMPILER_ID}" STREQUAL "GNU")
-+if ("${CMAKE_C_COMPILER_ID}" STREQUAL "GNU" OR "${CMAKE_C_COMPILER_ID}" STREQUAL "Clang")
- set(CMAKE_C_FLAGS "${CMAKE_C_FLAGS} -ffunction-sections -fdata-sections")
- if ("${DISABLE_WERROR}" STREQUAL "OFF")
- set(CMAKE_C_FLAGS "${CMAKE_C_FLAGS} -Werror")