aboutsummaryrefslogtreecommitdiffstats
path: root/package/kernel
diff options
context:
space:
mode:
Diffstat (limited to 'package/kernel')
-rw-r--r--package/kernel/linux/modules/hwmon.mk14
1 files changed, 14 insertions, 0 deletions
diff --git a/package/kernel/linux/modules/hwmon.mk b/package/kernel/linux/modules/hwmon.mk
index b75c741ba0..42df3a94f7 100644
--- a/package/kernel/linux/modules/hwmon.mk
+++ b/package/kernel/linux/modules/hwmon.mk
@@ -519,6 +519,20 @@ endef
$(eval $(call KernelPackage,hwmon-tmp421))
+define KernelPackage/hwmon-tps23861
+ TITLE:=Texas Instruments TPS23861 PoE PSE
+ KCONFIG:=CONFIG_SENSORS_TPS23861
+ FILES:=$(LINUX_DIR)/drivers/hwmon/tps23861.ko
+ AUTOLOAD:=$(call AutoProbe,tps23861)
+ $(call AddDepends/hwmon,+kmod-i2c-core)
+endef
+
+define KernelPackage/hwmon-tps23861/description
+ Kernel module for the Texas Instruments TPS23861 802.3at PoE PSE chips.
+endef
+
+$(eval $(call KernelPackage,hwmon-tps23861))
+
define KernelPackage/hwmon-vid
TITLE:=VID/VRM/VRD voltage conversion module.
KCONFIG:=CONFIG_HWMON_VID