aboutsummaryrefslogtreecommitdiffstats
path: root/include/prereq-build.mk
diff options
context:
space:
mode:
Diffstat (limited to 'include/prereq-build.mk')
-rw-r--r--include/prereq-build.mk4
1 files changed, 4 insertions, 0 deletions
diff --git a/include/prereq-build.mk b/include/prereq-build.mk
index 9c0717d53a..c3b88db627 100644
--- a/include/prereq-build.mk
+++ b/include/prereq-build.mk
@@ -24,6 +24,10 @@ $(eval $(call TestHostCommand,case-sensitive-fs, \
rm -f $(TMP_DIR)/test.*; touch $(TMP_DIR)/test.fs; \
test ! -f $(TMP_DIR)/test.FS))
+$(eval $(call TestHostCommand,proper-umask, \
+ Please build with umask 022 - other values produce broken packages, \
+ umask | grep -xF 0022))
+
$(eval $(call SetupHostCommand,gcc, \
Please install the GNU C Compiler (gcc), \
$(CC) --version | grep gcc, \