aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--target/linux/ath79/dts/ar9342_zyxel_nwa1123-ac.dts35
-rw-r--r--target/linux/ath79/generic/base-files/etc/board.d/02_network1
-rw-r--r--target/linux/ath79/generic/base-files/etc/hotplug.d/ieee80211/10_fix_wifi_mac4
-rw-r--r--target/linux/ath79/image/generic.mk10
4 files changed, 50 insertions, 0 deletions
diff --git a/target/linux/ath79/dts/ar9342_zyxel_nwa1123-ac.dts b/target/linux/ath79/dts/ar9342_zyxel_nwa1123-ac.dts
new file mode 100644
index 0000000000..68d4930813
--- /dev/null
+++ b/target/linux/ath79/dts/ar9342_zyxel_nwa1123-ac.dts
@@ -0,0 +1,35 @@
+// SPDX-License-Identifier: GPL-2.0-or-later OR MIT
+
+#include "ar9342_zyxel_nwa11xx.dtsi"
+
+/ {
+ compatible = "zyxel,nwa1123-ac", "qca,ar9342";
+ model = "Zyxel NWA1123-AC";
+
+ aliases {
+ label-mac-device = &eth0;
+ led-boot = &led_status_green;
+ led-failsafe = &led_status_amber;
+ led-running = &led_status_green;
+ led-upgrade = &led_status_amber;
+ };
+
+ leds {
+ compatible = "gpio-leds";
+
+ led_status_green: status_green {
+ label = "green:status";
+ gpios = <&gpio 12 GPIO_ACTIVE_LOW>;
+ default-state = "on";
+ };
+
+ led_status_amber: status_amber {
+ label = "amber:status";
+ gpios = <&gpio 11 GPIO_ACTIVE_LOW>;
+ };
+ };
+};
+
+&pcie {
+ status = "okay";
+};
diff --git a/target/linux/ath79/generic/base-files/etc/board.d/02_network b/target/linux/ath79/generic/base-files/etc/board.d/02_network
index f0bc9b3a9c..9656c009a1 100644
--- a/target/linux/ath79/generic/base-files/etc/board.d/02_network
+++ b/target/linux/ath79/generic/base-files/etc/board.d/02_network
@@ -111,6 +111,7 @@ ath79_setup_interfaces()
wd,mynet-wifi-rangeextender|\
winchannel,wb2000|\
zyxel,nwa1121-ni|\
+ zyxel,nwa1123-ac|\
zyxel,nwa1123-ni)
ucidef_set_interface_lan "eth0"
;;
diff --git a/target/linux/ath79/generic/base-files/etc/hotplug.d/ieee80211/10_fix_wifi_mac b/target/linux/ath79/generic/base-files/etc/hotplug.d/ieee80211/10_fix_wifi_mac
index 15bdf81a05..57458cdef0 100644
--- a/target/linux/ath79/generic/base-files/etc/hotplug.d/ieee80211/10_fix_wifi_mac
+++ b/target/linux/ath79/generic/base-files/etc/hotplug.d/ieee80211/10_fix_wifi_mac
@@ -68,6 +68,10 @@ case "$board" in
[ "$PHYNBR" -eq 1 ] && \
mtd_get_mac_ascii u-boot-env ethaddr > /sys${DEVPATH}/macaddress
;;
+ zyxel,nwa1123-ac)
+ [ "$PHYNBR" -eq 0 ] && \
+ mtd_get_mac_text mib0 0x66 > /sys${DEVPATH}/macaddress
+ ;;
zyxel,nwa1123-ni)
[ "$PHYNBR" -eq 1 ] && \
mtd_get_mac_text mib0 0x66 > /sys${DEVPATH}/macaddress
diff --git a/target/linux/ath79/image/generic.mk b/target/linux/ath79/image/generic.mk
index 617f1eed30..612b79f8d6 100644
--- a/target/linux/ath79/image/generic.mk
+++ b/target/linux/ath79/image/generic.mk
@@ -2716,6 +2716,16 @@ define Device/zyxel_nwa1121-ni
endef
TARGET_DEVICES += zyxel_nwa1121-ni
+define Device/zyxel_nwa1123-ac
+ $(Device/zyxel_nwa11xx)
+ DEVICE_MODEL := NWA1123
+ DEVICE_VARIANT := AC
+ ZYXEL_MODEL_STRING := AAOX
+ DEVICE_PACKAGES := kmod-ath10k-ct-smallbuffers \
+ ath10k-firmware-qca988x-ct
+endef
+TARGET_DEVICES += zyxel_nwa1123-ac
+
define Device/zyxel_nwa1123-ni
$(Device/zyxel_nwa11xx)
DEVICE_MODEL := NWA1123