diff options
-rw-r--r-- | Config.in | 9 | ||||
-rw-r--r-- | rules.mk | 2 |
2 files changed, 10 insertions, 1 deletions
@@ -173,6 +173,15 @@ choice endchoice +config STRIP_ARGS + string + prompt "Strip arguments" + depends USE_STRIP + default "--strip-unneeded --remove-section=.comment --remove-section=.note" if DEBUG + default "--strip-all" + help + Specifies arguments passed to the strip command when stripping binaries + config USE_MKLIBS bool "Strip unnecessary functions from libraries" help @@ -174,7 +174,7 @@ ifneq ($(CONFIG_NO_STRIP),) STRIP:=: else ifneq ($(CONFIG_USE_STRIP),) - STRIP:=$(TARGET_CROSS)strip + STRIP:=$(TARGET_CROSS)strip $(call qstrip,$(CONFIG_STRIP_ARGS)) else ifneq ($(CONFIG_USE_SSTRIP),) STRIP:=$(STAGING_DIR_HOST)/bin/sstrip |