aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux/s3c24xx/patches-2.6.30/055-jbt6k74.patch
diff options
context:
space:
mode:
authorLars-Peter Clausen <lars@metafoo.de>2009-05-18 17:55:41 +0000
committerLars-Peter Clausen <lars@metafoo.de>2009-05-18 17:55:41 +0000
commitf5affd4f36d839d706b02f1ffb69e0cf70c4140c (patch)
tree105a7093a2f5989136da5fe7128d6d95a3b9cad4 /target/linux/s3c24xx/patches-2.6.30/055-jbt6k74.patch
parent267af10b33745d098198ad9c1d2b5ab69efb128f (diff)
downloadupstream-f5affd4f36d839d706b02f1ffb69e0cf70c4140c.tar.gz
upstream-f5affd4f36d839d706b02f1ffb69e0cf70c4140c.tar.bz2
upstream-f5affd4f36d839d706b02f1ffb69e0cf70c4140c.zip
bump to 2.6.30-rc6
SVN-Revision: 15918
Diffstat (limited to 'target/linux/s3c24xx/patches-2.6.30/055-jbt6k74.patch')
-rw-r--r--target/linux/s3c24xx/patches-2.6.30/055-jbt6k74.patch30
1 files changed, 30 insertions, 0 deletions
diff --git a/target/linux/s3c24xx/patches-2.6.30/055-jbt6k74.patch b/target/linux/s3c24xx/patches-2.6.30/055-jbt6k74.patch
new file mode 100644
index 0000000000..5a5b742c9d
--- /dev/null
+++ b/target/linux/s3c24xx/patches-2.6.30/055-jbt6k74.patch
@@ -0,0 +1,30 @@
+Index: linux-2.6.30-rc6/drivers/video/display/Kconfig
+===================================================================
+--- linux-2.6.30-rc6.orig/drivers/video/display/Kconfig 2009-05-16 06:12:57.000000000 +0200
++++ linux-2.6.30-rc6/drivers/video/display/Kconfig 2009-05-18 19:08:33.000000000 +0200
+@@ -21,4 +21,15 @@
+ comment "Display hardware drivers"
+ depends on DISPLAY_SUPPORT
+
++config DISPLAY_JBT6K74
++ tristate "TPO JBT6K74-AS TFT display ASIC control interface"
++ depends on SPI_MASTER && SYSFS
++ help
++ SPI driver for the control interface of TFT panels containing
++ the TPO JBT6K74-AS controller ASIC, such as the TPO TD028TTEC1
++ TFT diplay module used in the Openmoko Freerunner GSM phone.
++
++ The control interface is required for display operation, as it
++ controls power management, display timing and gamma calibration.
++
+ endmenu
+Index: linux-2.6.30-rc6/drivers/video/display/Makefile
+===================================================================
+--- linux-2.6.30-rc6.orig/drivers/video/display/Makefile 2009-05-16 06:12:57.000000000 +0200
++++ linux-2.6.30-rc6/drivers/video/display/Makefile 2009-05-18 19:08:33.000000000 +0200
+@@ -3,4 +3,5 @@
+ display-objs := display-sysfs.o
+
+ obj-$(CONFIG_DISPLAY_SUPPORT) += display.o
++obj-$(CONFIG_DISPLAY_JBT6K74) += jbt6k74.o
+