aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux/ramips/image/mt7621.mk
diff options
context:
space:
mode:
authorLea Teuberth <lea.teuberth@outlook.com>2022-07-27 17:50:40 +0200
committerHauke Mehrtens <hauke@hauke-m.de>2022-08-06 19:58:46 +0200
commit45255aa0e870f09eac3954ad0df5a88f13d25ea9 (patch)
tree981a242a2bc2b3cbb3b6674fabb795fcb8dd0626 /target/linux/ramips/image/mt7621.mk
parent9edda3169f6ad8f2f20b6e540ecdced40d530585 (diff)
downloadupstream-45255aa0e870f09eac3954ad0df5a88f13d25ea9.tar.gz
upstream-45255aa0e870f09eac3954ad0df5a88f13d25ea9.tar.bz2
upstream-45255aa0e870f09eac3954ad0df5a88f13d25ea9.zip
ramips: adding support for Asus RP-AC56
Specifications: CPU: MT7621A dual-core 880MHz RAM: 64MB DDR2 FLASH: 16MB MX25L12805D NOR SPI WIFI: 2.4GHz 2x2 MT7603 b/g/n PCI WIFI: 5GHz 2x2 MT7662 a/b/ac PCI ETH: 1xLAN 1000base-T integrated SWITCH: MT7530 Port 0: LAN, Port 6: CPU LED: Power, 2.4GHz WiFi, 5GHz WiFi BTN: WPS, Reset UART: Near ETH port, from ETH: 3V3-TxD-GND-RxD 57600 8n1 MISC: Audio support Installation: 1. Update using recovery mode - while holdig "reset" button, power on the device - keep holding "reset" until power led is flashing yellow - set own IP to 192.168.1.75, subnet mask: 255.255.255.0 - push firmware image (can be factory.bin or sysupgrade.bin) using tftp client in binary mode to 192.168.1.1 Notes: This board has only two MAC addresses programmed in the "factory" partition: - MAC for wlan0 (2.4GHz) at offset 0x0004 - MAC for wlan1 (5GHz) at offset 0x8004 - stock firmware re-uses wlan0 MAC for ethernet - no valid addresses found in 0x28, 0x2e, 0xe000 and 0xe006 Signed-off-by: Lea Teuberth <lea.teuberth@outlook.com>
Diffstat (limited to 'target/linux/ramips/image/mt7621.mk')
-rw-r--r--target/linux/ramips/image/mt7621.mk16
1 files changed, 16 insertions, 0 deletions
diff --git a/target/linux/ramips/image/mt7621.mk b/target/linux/ramips/image/mt7621.mk
index b560ce3d95..7cda0c8f75 100644
--- a/target/linux/ramips/image/mt7621.mk
+++ b/target/linux/ramips/image/mt7621.mk
@@ -189,6 +189,22 @@ define Device/asiarf_ap7621-nv1
endef
TARGET_DEVICES += asiarf_ap7621-nv1
+define Device/asus_rp-ac56
+ $(Device/dsa-migration)
+ $(Device/uimage-lzma-loader)
+ DEVICE_VENDOR := ASUS
+ DEVICE_MODEL := RP-AC56
+ IMAGE_SIZE := 16000k
+ BLOCKSIZE := 64k
+ DEVICE_PACKAGES := kmod-mt7603 kmod-mt76x2 \
+ kmod-i2c-ralink kmod-sound-mt7620
+ IMAGES += factory.bin
+ IMAGE/factory.bin := append-kernel | append-rootfs | pad-rootfs | check-size
+ IMAGE/sysupgrade.bin := append-kernel | append-rootfs | pad-rootfs | \
+ check-size | append-metadata
+endef
+TARGET_DEVICES += asus_rp-ac56
+
define Device/asus_rp-ac87
$(Device/dsa-migration)
$(Device/uimage-lzma-loader)