aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux/ramips/image/mt7621.mk
diff options
context:
space:
mode:
authorAlexander Horner <ahorner@programmer.net>2022-09-26 20:17:40 +0100
committerHauke Mehrtens <hauke@hauke-m.de>2022-11-05 21:12:25 +0100
commit53f2e438cb58a8f7b8d0d01f941aca9682be1e82 (patch)
tree6ce5bd3b57ecd3728c76ffe8bb20b52ad25a15a6 /target/linux/ramips/image/mt7621.mk
parent7a504c151d26210addc66f029dacda13fb662bdd (diff)
downloadupstream-53f2e438cb58a8f7b8d0d01f941aca9682be1e82.tar.gz
upstream-53f2e438cb58a8f7b8d0d01f941aca9682be1e82.tar.bz2
upstream-53f2e438cb58a8f7b8d0d01f941aca9682be1e82.zip
ramips: add support for Zbtlink ZBT-WG1602-V04
Description heavily based on commit 7e89421a7c3855d66a20350a5bf9ca4cc7a2caf9 by Sergey Ryazanov <ryazanov.s.a@gmail.com> Details I cannot confirm have been removed Completed with great help from \x on IRC. Thanks, \x! Zbtlink ZBT-WG1602-V04 is a Wi-Fi router intendend for use with WWAN (UMTS/LTE/3G/4G) modems. The router board offers a couple of miniPCIe slots with USB and SIM only and another one which is a pure miniPCIe slot as well as five Gigabit Ethernet ports (4xLAN + WAN). Specification: * SoC: MT7621A * RAM: 256/512 MiB * Flash: 16/32 MiB * Eth: 10/100/1000 Mbps Ethernet x5 ports (4xLAN + WAN) * WLAN 2GHz: MT7603E (.11bgn, MIMO 2x2) * WLAN 5GHz: MT7662E (.11nac, MIMO 2x2) * WLAN Ants: detachable x2, shared by 2GHz & 5GHz radios * miniPCIe: 2x slots with USB&SIM + 1x slot with regular PCIe bus * WWAN Ants: detachable x4 * External storage: microSD (SDXC) slot * USB: 3.0 Type-A port * LED: 11 (5 per Eth phy, 3 SoC controlled, 2 WLAN 2/5 controlled, 1 power indicator) * Button: 1 (reset) * UART: console (115200 baud) * Power: DC jack (12 V / 2.5 A) Additional HW information: * SoC USB port 1 is shared by internal miniPCIe slot and external Type-A USB port, USB D+/D- lines are toggled between ports using a GPIO controlled DPDT switch. Installation: The kernel image can be installed directly onto the device via a browser to 192.168.1.1 using the built in firmware recovery Web UI available. It can be accessed by pushing the reset button in, applying power and holding the reset button for approximately 10 seconds. When the kernel image has been flashed, you can access LuCI and upload the sysupgrade as normal. Signed-off-by: Alexander Horner <ahorner@programmer.net>
Diffstat (limited to 'target/linux/ramips/image/mt7621.mk')
-rw-r--r--target/linux/ramips/image/mt7621.mk24
1 files changed, 24 insertions, 0 deletions
diff --git a/target/linux/ramips/image/mt7621.mk b/target/linux/ramips/image/mt7621.mk
index 360513115f..a819abd968 100644
--- a/target/linux/ramips/image/mt7621.mk
+++ b/target/linux/ramips/image/mt7621.mk
@@ -2319,6 +2319,30 @@ define Device/zbtlink_zbt-wg1602-16m
endef
TARGET_DEVICES += zbtlink_zbt-wg1602-16m
+define Device/zbtlink_zbt-wg1602-v04-16m
+ $(Device/dsa-migration)
+ $(Device/uimage-lzma-loader)
+ IMAGE_SIZE := 16064k
+ DEVICE_VENDOR := Zbtlink
+ DEVICE_MODEL := ZBT-WG1602-V04
+ DEVICE_VARIANT := 16M
+ DEVICE_PACKAGES := kmod-sdhci-mt7620 kmod-mt7603 kmod-mt76x2 kmod-usb3 \
+ kmod-usb-ledtrig-usbport
+endef
+TARGET_DEVICES += zbtlink_zbt-wg1602-v04-16m
+
+define Device/zbtlink_zbt-wg1602-v04-32m
+ $(Device/dsa-migration)
+ $(Device/uimage-lzma-loader)
+ IMAGE_SIZE := 32128k
+ DEVICE_VENDOR := Zbtlink
+ DEVICE_MODEL := ZBT-WG1602-V04
+ DEVICE_VARIANT := 32M
+ DEVICE_PACKAGES := kmod-sdhci-mt7620 kmod-mt7603 kmod-mt76x2 kmod-usb3 \
+ kmod-usb-ledtrig-usbport
+endef
+TARGET_DEVICES += zbtlink_zbt-wg1602-v04-32m
+
define Device/zbtlink_zbt-wg1608-16m
$(Device/dsa-migration)
$(Device/uimage-lzma-loader)