aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux/openmoko/image/Makefile
diff options
context:
space:
mode:
authorMichael Büsch <mb@bu3sch.de>2008-12-11 22:20:51 +0000
committerMichael Büsch <mb@bu3sch.de>2008-12-11 22:20:51 +0000
commite2fb36c8659874c361a99e3e4255f660acbae7a2 (patch)
treef04d62e2fa21e14834dc6c658836e141e5d55c3e /target/linux/openmoko/image/Makefile
parent1e9300de8b1d263a95e7aa9efe6ac797309d5ae4 (diff)
downloadupstream-e2fb36c8659874c361a99e3e4255f660acbae7a2.tar.gz
upstream-e2fb36c8659874c361a99e3e4255f660acbae7a2.tar.bz2
upstream-e2fb36c8659874c361a99e3e4255f660acbae7a2.zip
Add basic framework for the openmoko platform. The kernel does build and boot, but the rootfs build process is not completely implemented, yet.
SVN-Revision: 13605
Diffstat (limited to 'target/linux/openmoko/image/Makefile')
-rw-r--r--target/linux/openmoko/image/Makefile28
1 files changed, 28 insertions, 0 deletions
diff --git a/target/linux/openmoko/image/Makefile b/target/linux/openmoko/image/Makefile
new file mode 100644
index 0000000000..20f17590f3
--- /dev/null
+++ b/target/linux/openmoko/image/Makefile
@@ -0,0 +1,28 @@
+#
+# Copyright (C) 2008 OpenWrt.org
+#
+# This is free software, licensed under the GNU General Public License v2.
+# See /LICENSE for more information.
+#
+
+include $(TOPDIR)/rules.mk
+include $(INCLUDE_DIR)/image.mk
+
+define Build/Clean
+endef
+
+define Build/Compile
+endef
+
+define Image/Prepare
+ cp $(LINUX_DIR)/arch/arm/boot/uImage $(KDIR)/uImage
+endef
+
+define Image/BuildKernel
+ cp $(KDIR)/uImage $(BIN_DIR)/openwrt-$(BOARD)-uImage
+endef
+
+define Image/Build
+endef
+
+$(eval $(call BuildImage))