aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux/openmoko/Makefile
diff options
context:
space:
mode:
authorMichael Büsch <mb@bu3sch.de>2008-12-11 22:20:51 +0000
committerMichael Büsch <mb@bu3sch.de>2008-12-11 22:20:51 +0000
commite2fb36c8659874c361a99e3e4255f660acbae7a2 (patch)
treef04d62e2fa21e14834dc6c658836e141e5d55c3e /target/linux/openmoko/Makefile
parent1e9300de8b1d263a95e7aa9efe6ac797309d5ae4 (diff)
downloadupstream-e2fb36c8659874c361a99e3e4255f660acbae7a2.tar.gz
upstream-e2fb36c8659874c361a99e3e4255f660acbae7a2.tar.bz2
upstream-e2fb36c8659874c361a99e3e4255f660acbae7a2.zip
Add basic framework for the openmoko platform. The kernel does build and boot, but the rootfs build process is not completely implemented, yet.
SVN-Revision: 13605
Diffstat (limited to 'target/linux/openmoko/Makefile')
-rw-r--r--target/linux/openmoko/Makefile24
1 files changed, 24 insertions, 0 deletions
diff --git a/target/linux/openmoko/Makefile b/target/linux/openmoko/Makefile
new file mode 100644
index 0000000000..22bfaea57f
--- /dev/null
+++ b/target/linux/openmoko/Makefile
@@ -0,0 +1,24 @@
+#
+# Copyright (C) 2008 OpenWrt.org
+#
+# This is free software, licensed under the GNU General Public License v2.
+# See /LICENSE for more information.
+#
+include $(TOPDIR)/rules.mk
+
+ARCH:=arm
+BOARD:=openmoko
+BOARDNAME:=Openmoko
+FEATURES:=squashfs usb
+
+LINUX_VERSION:=2.6.24.7
+
+include $(INCLUDE_DIR)/target.mk
+
+KERNELNAME:="uImage"
+
+define Target/Description
+ Build fimware images for the Openmoko Smartphone.
+endef
+
+$(eval $(call BuildTarget))