aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux/mediatek/image
diff options
context:
space:
mode:
authorDavid Bauer <mail@david-bauer.net>2023-01-26 17:39:43 +0100
committerDavid Bauer <mail@david-bauer.net>2023-03-24 20:30:29 +0100
commite7c399bee677e9bac66e1bea697aefb8d828edfe (patch)
tree2b8fd16d510e19253da3a189a81883644956fea5 /target/linux/mediatek/image
parent652d5ac1526ffb5e5d5894dbde4064b2d56723e0 (diff)
downloadupstream-e7c399bee677e9bac66e1bea697aefb8d828edfe.tar.gz
upstream-e7c399bee677e9bac66e1bea697aefb8d828edfe.tar.bz2
upstream-e7c399bee677e9bac66e1bea697aefb8d828edfe.zip
filogic: add support for ASUS TUF-AX4200
Hardware -------- SOC: MediaTek MT7986 RAM: 512MB DDR3 FLASH: 256MB SPI-NAND (Winbond W25N02KV) WIFI: Mediatek MT7986 DBDC 802.11ax 2.4/5 GHz ETH: MediaTek MT7531 Switch MaxLinear GPY211C 2.5 N-Base-T PHY UART: 3V3 115200 8N1 (Pinout silkscreened / Do not ocnnect VCC) Installation ------------ 1. Download the OpenWrt initramfs image. Copy the image to a TFTP server reachable at 192.168.1.66/24. Rename the image to tufax4200.bin. 2. Connect the TFTP server to the AX4200. Conect to the serial console, interrupt the autoboot process by pressing '4' when prompted. 3. Download & Boot the OpenWrt initramfs image. $ setenv ipaddr 192.168.1.1 $ setenv serverip 192.168.1.66 $ tftpboot 0x46000000 tufax4200.bin $ bootm 0x46000000 4. Wait for OpenWrt to boot. Transfer the sysupgrade image to the device using scp and install using sysupgrade. $ sysupgrade -n <path-to-sysupgrade.bin> Missing features ---------------- - The LAN port LEDs are driven by the switch but OpenWrt does not correctly configure the output. Signed-off-by: David Bauer <mail@david-bauer.net>
Diffstat (limited to 'target/linux/mediatek/image')
-rw-r--r--target/linux/mediatek/image/filogic.mk18
1 files changed, 18 insertions, 0 deletions
diff --git a/target/linux/mediatek/image/filogic.mk b/target/linux/mediatek/image/filogic.mk
index 5c223d04ff..2e9becb241 100644
--- a/target/linux/mediatek/image/filogic.mk
+++ b/target/linux/mediatek/image/filogic.mk
@@ -38,6 +38,24 @@ define Build/mt7986-gpt
rm $@.tmp
endef
+define Device/asus_tuf-ax4200
+ DEVICE_VENDOR := ASUS
+ DEVICE_MODEL := TUF-AX4200
+ DEVICE_DTS := mt7986a-asus-tuf-ax4200
+ DEVICE_DTS_DIR := ../dts
+ DEVICE_DTS_LOADADDR := 0x47000000
+ DEVICE_PACKAGES := kmod-usb3
+ IMAGES := sysupgrade.bin
+ KERNEL_LOADADDR := 0x48000000
+ KERNEL = kernel-bin | lzma | \
+ fit lzma $$(KDIR)/image-$$(firstword $$(DEVICE_DTS)).dtb
+ KERNEL_INITRAMFS := kernel-bin | lzma | \
+ fit lzma $$(KDIR)/image-$$(firstword $$(DEVICE_DTS)).dtb with-initrd | pad-to 64k
+ IMAGE/sysupgrade.bin := sysupgrade-tar | append-metadata
+endef
+TARGET_DEVICES += asus_tuf-ax4200
+
+
define Device/bananapi_bpi-r3
DEVICE_VENDOR := Bananapi
DEVICE_MODEL := BPi-R3