aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux/mediatek/image
diff options
context:
space:
mode:
authorChuanhong Guo <gch981213@gmail.com>2022-12-30 15:55:56 +0800
committerChuanhong Guo <gch981213@gmail.com>2022-12-30 16:11:59 +0800
commitd29dbf052a1d34d7891b67177e1739db5d5af0bb (patch)
treeacdcba1e154ef6ccae748cb806d1060e8c62eb43 /target/linux/mediatek/image
parent7272203022e38bc125ced9831ae1983fe3a34f45 (diff)
downloadupstream-d29dbf052a1d34d7891b67177e1739db5d5af0bb.tar.gz
upstream-d29dbf052a1d34d7891b67177e1739db5d5af0bb.tar.bz2
upstream-d29dbf052a1d34d7891b67177e1739db5d5af0bb.zip
mediatek: drop redmi-ax6000 variant with modified env
This variant uses xiaomi factory u-boot and modified u-boot-env & bootcmd. By modifying uboot-env, the xiaomi firmware recovery provided in the vendor u-boot doesn't work anymore. It's possible to put u-boot into a state where it refuese to take any serial input. If the u-boot is in this state, users can't restore their firmware without taking the flash off the board. We now have a -stock variant where the vendor u-boot is used in a way that xiaomi firmware recovery still works, and a -ubootmod variant where we get rid of all xiaomi components, have more usable space and no uart console lock. These two should cover all use cases and we don't need this variant anymore. Drop this redmi-ax6000 variant. Existing users of this variant should perform a u-boot mod or restore to the -stock layout. Signed-off-by: Chuanhong Guo <gch981213@gmail.com>
Diffstat (limited to 'target/linux/mediatek/image')
-rw-r--r--target/linux/mediatek/image/filogic.mk15
1 files changed, 0 insertions, 15 deletions
diff --git a/target/linux/mediatek/image/filogic.mk b/target/linux/mediatek/image/filogic.mk
index 4b16cff56e..5c223d04ff 100644
--- a/target/linux/mediatek/image/filogic.mk
+++ b/target/linux/mediatek/image/filogic.mk
@@ -125,21 +125,6 @@ define Device/mediatek_mt7986b-rfb
endef
TARGET_DEVICES += mediatek_mt7986b-rfb
-define Device/xiaomi_redmi-router-ax6000
- DEVICE_VENDOR := Xiaomi
- DEVICE_MODEL := Redmi Router AX6000
- DEVICE_DTS := mt7986a-xiaomi-redmi-router-ax6000
- DEVICE_DTS_DIR := ../dts
- DEVICE_PACKAGES := kmod-leds-ws2812b
- KERNEL_LOADADDR := 0x48000000
- UBINIZE_OPTS := -E 5
- BLOCKSIZE := 128k
- PAGESIZE := 2048
- KERNEL_IN_UBI := 1
- IMAGE/sysupgrade.bin := sysupgrade-tar | append-metadata
-endef
-TARGET_DEVICES += xiaomi_redmi-router-ax6000
-
define Device/xiaomi_redmi-router-ax6000-stock
DEVICE_VENDOR := Xiaomi
DEVICE_MODEL := Redmi Router AX6000 (stock layout)