aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux/mediatek/image
diff options
context:
space:
mode:
authorFlole Systems <flole@flole.de>2023-04-10 23:36:59 +0200
committerStefan Agner <stefan@agner.ch>2023-06-26 13:20:39 +0200
commitcd17d8df2a38ccdd98aa1a7b361aa255d53ea5ac (patch)
treee428afebf46740ff9a5dc000ad1a3339cc6846fc /target/linux/mediatek/image
parent106c83a1eafcccb6059a0427953b7780d184c692 (diff)
downloadupstream-cd17d8df2a38ccdd98aa1a7b361aa255d53ea5ac.tar.gz
upstream-cd17d8df2a38ccdd98aa1a7b361aa255d53ea5ac.tar.bz2
upstream-cd17d8df2a38ccdd98aa1a7b361aa255d53ea5ac.zip
filogic: add support for Netgear WAX220
Hardware -------- SOC: MediaTek MT7986 RAM: 1024MB DDR3 FLASH: 128MB SPI-NAND (Winbond) WIFI: Mediatek MT7986 DBDC 802.11ax 2.4/5 GHz ETH: Realtek RTL8221B-VB-CG 2.5 N-Base-T PHY with PoE UART: 3V3 115200 8N1 (Pinout silkscreened / Do not connect VCC) Installation ------------ 1. Download the OpenWrt initramfs image. Copy the image to a TFTP server 2. Connect the TFTP server to the WAX220. Conect to the serial console, interrupt the autoboot process by pressing '0' when prompted. 3. Download & Boot the OpenWrt initramfs image. $ setenv ipaddr 192.168.2.1 $ setenv serverip 192.168.2.2 $ tftpboot openwrt.bin $ bootm 4. Wait for OpenWrt to boot. Transfer the sysupgrade image to the device using scp and install using sysupgrade. $ sysupgrade -n <path-to-sysupgrade.bin> Signed-off-by: Flole Systems <flole@flole.de> Signed-off-by: Stefan Agner <stefan@agner.ch> (cherry picked from commit 984786a2f7ec622c99e8c9cdada65d0ea0cf4e0b)
Diffstat (limited to 'target/linux/mediatek/image')
-rw-r--r--target/linux/mediatek/image/filogic.mk16
1 files changed, 16 insertions, 0 deletions
diff --git a/target/linux/mediatek/image/filogic.mk b/target/linux/mediatek/image/filogic.mk
index 6323a05de2..ae25aee2ed 100644
--- a/target/linux/mediatek/image/filogic.mk
+++ b/target/linux/mediatek/image/filogic.mk
@@ -176,6 +176,22 @@ define Device/glinet_gl-mt3000
endef
TARGET_DEVICES += glinet_gl-mt3000
+define Device/netgear_wax220
+ DEVICE_VENDOR := Netgear
+ DEVICE_MODEL := WAX220
+ DEVICE_DTS := mt7986b-netgear-wax220
+ DEVICE_DTS_DIR := ../dts
+ DEVICE_PACKAGES := kmod-mt7986-firmware mt7986-wo-firmware
+ IMAGES := sysupgrade.bin
+ KERNEL_IN_UBI := 1
+ KERNEL := kernel-bin | lzma | \
+ fit lzma $$(KDIR)/image-$$(firstword $$(DEVICE_DTS)).dtb
+ KERNEL_INITRAMFS := kernel-bin | lzma | \
+ fit lzma $$(KDIR)/image-$$(firstword $$(DEVICE_DTS)).dtb with-initrd | pad-to 64k
+ IMAGE/sysupgrade.bin := sysupgrade-tar | append-metadata
+endef
+TARGET_DEVICES += netgear_wax220
+
define Device/mediatek_mt7986a-rfb-nand
DEVICE_VENDOR := MediaTek
DEVICE_MODEL := MT7986 rfba AP (NAND)