aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux/mediatek/image
diff options
context:
space:
mode:
authorFelix Fietkau <nbd@nbd.name>2022-10-29 23:03:08 +0200
committerFelix Fietkau <nbd@nbd.name>2022-11-09 20:43:45 +0100
commit4f1e54801ef9d43c6202f007f0ce8fcbee2ed369 (patch)
treefc5e21b4ee2adc3d25b56201b4100f9f4dd466e9 /target/linux/mediatek/image
parentb8bf27e4cb2d4c6ff4c75274c0e1d1619eef7f10 (diff)
downloadupstream-4f1e54801ef9d43c6202f007f0ce8fcbee2ed369.tar.gz
upstream-4f1e54801ef9d43c6202f007f0ce8fcbee2ed369.tar.bz2
upstream-4f1e54801ef9d43c6202f007f0ce8fcbee2ed369.zip
mediatek: drop the use of device tree overlays on mt7986a-rfb board
The boot loader does not support it. Instead make NAND the default image for this board Signed-off-by: Felix Fietkau <nbd@nbd.name>
Diffstat (limited to 'target/linux/mediatek/image')
-rw-r--r--target/linux/mediatek/image/filogic.mk15
1 files changed, 7 insertions, 8 deletions
diff --git a/target/linux/mediatek/image/filogic.mk b/target/linux/mediatek/image/filogic.mk
index f7fc9e30d1..1ece1465c2 100644
--- a/target/linux/mediatek/image/filogic.mk
+++ b/target/linux/mediatek/image/filogic.mk
@@ -84,14 +84,13 @@ define Device/bananapi_bpi-r3
endef
TARGET_DEVICES += bananapi_bpi-r3
-define Device/mediatek_mt7986a-rfb
+define Device/mediatek_mt7986a-rfb-nand
DEVICE_VENDOR := MediaTek
- DEVICE_MODEL := MTK7986 rfba AP
- DEVICE_DTS := mt7986a-rfb
+ DEVICE_MODEL := MT7986 rfba AP (NAND)
+ DEVICE_DTS := mt7986a-rfb-spim-nand
DEVICE_DTS_DIR := $(DTS_DIR)/
KERNEL_LOADADDR := 0x48000000
- DEVICE_DTS_OVERLAY := mt7986a-rfb-spim-nand mt7986a-rfb-spim-nor
- SUPPORTED_DEVICES := mediatek,mt7986a-rfb
+ SUPPORTED_DEVICES := mediatek,mt7986a-rfb-snand
UBINIZE_OPTS := -E 5
BLOCKSIZE := 128k
PAGESIZE := 2048
@@ -101,12 +100,12 @@ define Device/mediatek_mt7986a-rfb
IMAGE/factory.bin := append-ubi | check-size $$$$(IMAGE_SIZE)
IMAGE/sysupgrade.bin := sysupgrade-tar | append-metadata
KERNEL = kernel-bin | lzma | \
- fit lzma $$(KDIR)/$$(firstword $$(DEVICE_DTS)).dtb
+ fit lzma $$(KDIR)/image-$$(firstword $$(DEVICE_DTS)).dtb
KERNEL_INITRAMFS = kernel-bin | lzma | \
- fit lzma $$(KDIR)/$$(firstword $$(DEVICE_DTS)).dtb with-initrd
+ fit lzma $$(KDIR)/image-$$(firstword $$(DEVICE_DTS)).dtb with-initrd
DTC_FLAGS += -@ --space 32768
endef
-TARGET_DEVICES += mediatek_mt7986a-rfb
+TARGET_DEVICES += mediatek_mt7986a-rfb-nand
define Device/mediatek_mt7986b-rfb
DEVICE_VENDOR := MediaTek