aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux/mediatek/image
diff options
context:
space:
mode:
authorHenrik Riomar <henrik.riomar@gmail.com>2022-05-31 19:18:06 +0200
committerDaniel Golle <daniel@makrotopia.org>2022-06-11 19:50:26 +0100
commit15a02471bb854245f8f94398c1e1d9ce29c2c341 (patch)
tree1959ca85154e85e7cfe8380ba41054975647bed3 /target/linux/mediatek/image
parente3e9eb31a281643737142e8e80c6f49204b5ba18 (diff)
downloadupstream-15a02471bb854245f8f94398c1e1d9ce29c2c341.tar.gz
upstream-15a02471bb854245f8f94398c1e1d9ce29c2c341.tar.bz2
upstream-15a02471bb854245f8f94398c1e1d9ce29c2c341.zip
mediatek: new target mt7622-ubnt-unifi-6-lr-v1
Based on current mt7622-ubnt-unifi-6-lr, this is a preparation for adding a v2 version of this target * v1 - with led-bar * v2 - two simple GPIO connected LEDs (in later commits) Signed-off-by: Daniel Golle <daniel@makrotopia.org> [added SUPPORTED_DEVICES for compatibility with existing setups] Signed-off-by: Henrik Riomar <henrik.riomar@gmail.com>
Diffstat (limited to 'target/linux/mediatek/image')
-rw-r--r--target/linux/mediatek/image/mt7622.mk8
1 files changed, 5 insertions, 3 deletions
diff --git a/target/linux/mediatek/image/mt7622.mk b/target/linux/mediatek/image/mt7622.mk
index aba8bdfe0b..d6308f2ef6 100644
--- a/target/linux/mediatek/image/mt7622.mk
+++ b/target/linux/mediatek/image/mt7622.mk
@@ -242,15 +242,17 @@ define Device/totolink_a8000ru
endef
TARGET_DEVICES += totolink_a8000ru
-define Device/ubnt_unifi-6-lr
+define Device/ubnt_unifi-6-lr-v1
DEVICE_VENDOR := Ubiquiti
DEVICE_MODEL := UniFi 6 LR
+ DEVICE_VARIANT := v1
DEVICE_DTS_CONFIG := config@1
- DEVICE_DTS := mt7622-ubnt-unifi-6-lr
+ DEVICE_DTS := mt7622-ubnt-unifi-6-lr-v1
DEVICE_DTS_DIR := ../dts
DEVICE_PACKAGES := kmod-mt7915e kmod-leds-ubnt-ledbar
+ SUPPORTED_DEVICES += ubnt,unifi-6-lr
endef
-TARGET_DEVICES += ubnt_unifi-6-lr
+TARGET_DEVICES += ubnt_unifi-6-lr-v1
define Device/ubnt_unifi-6-lr-ubootmod
DEVICE_VENDOR := Ubiquiti